aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhashashini <lavez@gmx.de>2014-09-14 15:06:01 +0200
committerDavide Pesavento <pesa@gentoo.org>2014-09-16 00:59:05 +0200
commit58d027ad283eb3aec4c6b283a20949418785788e (patch)
treee47bec0bfc9f13bc5547f038b1025cec67e50d77 /x11-terms
parent[sets/lxqt-live] Add lxqt-qtplugin. (diff)
downloadqt-58d027ad283eb3aec4c6b283a20949418785788e.tar.gz
qt-58d027ad283eb3aec4c6b283a20949418785788e.tar.bz2
qt-58d027ad283eb3aec4c6b283a20949418785788e.zip
[qtermwidget,qterminal] Add qt5 support to live ebuilds.
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/qterminal/qterminal-9999.ebuild40
1 files changed, 29 insertions, 11 deletions
diff --git a/x11-terms/qterminal/qterminal-9999.ebuild b/x11-terms/qterminal/qterminal-9999.ebuild
index 658e33fd..7dc83b69 100644
--- a/x11-terms/qterminal/qterminal-9999.ebuild
+++ b/x11-terms/qterminal/qterminal-9999.ebuild
@@ -2,22 +2,40 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
-inherit cmake-utils git-2
+inherit cmake-utils git-r3
-DESCRIPTION="Qt4-based multitab terminal emulator"
-HOMEPAGE="https://github.com/qterminal/"
-EGIT_REPO_URI="git://github.com/qterminal/qterminal.git"
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://github.com/qterminal/qterminal"
+EGIT_REPO_URI="https://github.com/qterminal/qterminal.git"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
-IUSE="debug"
+IUSE="debug qt4 qt5"
-DEPEND="dev-qt/qtgui:4
- x11-libs/libqxt
- x11-libs/qtermwidget"
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+DEPEND="
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-libs/libqxt
+ ~x11-libs/qtermwidget-${PV}[qt4(+)]
+ )
+ qt5? (
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ ~x11-libs/qtermwidget-${PV}[qt5(-)]
+ )"
RDEPEND="${DEPEND}"
-#todo: translations
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use qt5)
+ $(cmake-utils_use_use qt4 SYSTEM_QXT)
+ )
+ cmake-utils_src_configure
+}