aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-05-25 23:31:56 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-05-25 23:31:56 +0300
commitc9255c98c34a4a9954a5f9ea9e76dd3ebe8daa0c (patch)
treeee609b77c855b565f71d518c93bf9d12a501a38a /x11-terms
parentx11-libs/qtermwidget: add 2.0.0 (diff)
downloadqt-c9255c98c34a4a9954a5f9ea9e76dd3ebe8daa0c.tar.gz
qt-c9255c98c34a4a9954a5f9ea9e76dd3ebe8daa0c.tar.bz2
qt-c9255c98c34a4a9954a5f9ea9e76dd3ebe8daa0c.zip
x11-terms/qterminal: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/qterminal/Manifest1
-rw-r--r--x11-terms/qterminal/qterminal-2.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-terms/qterminal/Manifest b/x11-terms/qterminal/Manifest
new file mode 100644
index 00000000..9f9ced14
--- /dev/null
+++ b/x11-terms/qterminal/Manifest
@@ -0,0 +1 @@
+DIST qterminal-2.0.0.tar.xz 228584 BLAKE2B 5c1bbd536659becd3708806a46a967bd35b479947cdca0412d0b2fecd31ce64f1dc71266dd48f3280fbac4e3e534c5b99e43442a63b139fb8789f443e1c67197 SHA512 455ca913f38eed881af50eb17d4798985d546c3c633d4df8887316abd4a56e76d1f716dcaece471e092471c0381a328ca685ec27f4d4690e89087166dc7fb0a3
diff --git a/x11-terms/qterminal/qterminal-2.0.0.ebuild b/x11-terms/qterminal/qterminal-2.0.0.ebuild
new file mode 100644
index 00000000..5e4b94e0
--- /dev/null
+++ b/x11-terms/qterminal/qterminal-2.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND=">=dev-util/lxqt-build-tools-2.0.0"
+DEPEND="
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ x11-libs/libX11
+ ~x11-libs/qtermwidget-${PV}:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}