aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-04-02 06:52:05 -0500
committerBen Kohler <bkohler@gentoo.org>2024-04-02 06:53:43 -0500
commite86116180e075f161fff1cc5b11ecd377137968a (patch)
tree112f5925ae3c3a876d23a805629e96049ceb52f9
parentSwitch arm64 bootmedia uploads to 23.0 (diff)
downloadreleng-e86116180e075f161fff1cc5b11ecd377137968a.tar.gz
releng-e86116180e075f161fff1cc5b11ecd377137968a.tar.bz2
releng-e86116180e075f161fff1cc5b11ecd377137968a.zip
catalyst-auto: extra echo to debug CLST_AUTO_NOCLEAN
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rwxr-xr-xtools/catalyst-auto1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/catalyst-auto b/tools/catalyst-auto
index 9624cebb..04db65e7 100755
--- a/tools/catalyst-auto
+++ b/tools/catalyst-auto
@@ -544,6 +544,7 @@ run_catalyst_commands() {
specpath=$(readlink -f "${i}")
# Bail out of cleaning (eg) stage3-openrc.spec failure if
# CLST_AUTO_NOCLEAN="stage3-openrc.spec" is set
+ run_cmd "${LOGFILE}" "${timeprefix[@]}" echo "Testing ${i} against CLST_AUTO_NOCLEAN=${CLST_AUTO_NOCLEAN}"
[[ ${CLST_AUTO_NOCLEAN} == *${i}* ]] ||
run_cmd "${LOGFILE}" "${timeprefix[@]}" catalyst --purgetmponly -c "${CATALYST_CONFIG}" -f "${specpath}"
done