aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorPeter Wilmott <p@p8952.info>2015-06-22 19:55:07 +0000
committerPeter Wilmott <p@p8952.info>2015-06-22 19:55:07 +0000
commitaa3bb2f4ac565031578d965c9757b457461bbbca (patch)
treec1f580ae815a53d444816afcd388eb7adbe3ffec /bin
parentAdd python linter (diff)
downloadruby-tinderbox-aa3bb2f4ac565031578d965c9757b457461bbbca.tar.gz
ruby-tinderbox-aa3bb2f4ac565031578d965c9757b457461bbbca.tar.bz2
ruby-tinderbox-aa3bb2f4ac565031578d965c9757b457461bbbca.zip
Fix most issues raised by linters, some python ones remain
Diffstat (limited to 'bin')
-rwxr-xr-xbin/get_stage3.sh2
-rwxr-xr-xbin/packages.py17
-rwxr-xr-xbin/provision.sh8
-rwxr-xr-xbin/repoman.sh3
-rwxr-xr-xbin/tinder.sh5
5 files changed, 22 insertions, 13 deletions
diff --git a/bin/get_stage3.sh b/bin/get_stage3.sh
index da04ec2..13a5ce1 100755
--- a/bin/get_stage3.sh
+++ b/bin/get_stage3.sh
@@ -7,5 +7,5 @@ LATEST_STAGE3=$(curl -s $DIST_MIRROR/releases/amd64/autobuilds/latest-stage3-amd
STAGE3_URI="$DIST_MIRROR/releases/amd64/autobuilds/$LATEST_STAGE3"
if [[ ! -f "$SCRIPT_DIR/../cache/stage3-amd64.tar.bz2" ]]; then
- curl -o "$SCRIPT_DIR/../cache/stage3-amd64.tar.bz2" $STAGE3_URI
+ curl -o "$SCRIPT_DIR/../cache/stage3-amd64.tar.bz2" "$STAGE3_URI"
fi
diff --git a/bin/packages.py b/bin/packages.py
index ed07e68..fc464e9 100755
--- a/bin/packages.py
+++ b/bin/packages.py
@@ -4,8 +4,10 @@ import portage, hashlib
def format_deps(dep_list):
for item in list(dep_list):
- if "||" in item: dep_list.remove(item)
- if "?" in item: dep_list.remove(item)
+ if "||" in item:
+ dep_list.remove(item)
+ if "?" in item:
+ dep_list.remove(item)
index = 0
for item in list(dep_list):
@@ -34,7 +36,14 @@ def get_deps(cpv):
def format_output(cpv, slot, iuse, keyword):
category, pkgname, version, revision = portage.catpkgsplit(cpv)
sha1 = hashlib.sha1(open(porttree.dbapi.findname(cpv), 'rb').read()).hexdigest()
- print (sha1 + ' ' + category + ' ' + pkgname + ' ' + version + ' ' + revision + ' ' + slot + ' ' + keyword, end=' ')
+ print(sha1 + ' ' + \
+ category + ' ' + \
+ pkgname + ' ' + \
+ version + ' ' + \
+ revision + ' ' + \
+ slot + ' ' + \
+ keyword, \
+ end=' ')
if 'ruby_targets_ruby19' in iuse:
print('ruby19', end=' ')
else:
@@ -66,7 +75,7 @@ for cp in porttree.dbapi.cp_all():
cpvbs = (porttree.dep_bestmatch(cp))
if cpvbs:
- slot, iuse, keywords = porttree.dbapi.aux_get(cpvbs, ['SLOT', 'IUSE','KEYWORDS'])
+ slot, iuse, keywords = porttree.dbapi.aux_get(cpvbs, ['SLOT', 'IUSE', 'KEYWORDS'])
if '~amd64' not in keywords and 'amd64' in keywords:
format_output(cpvbs, slot, iuse, 'amd64')
diff --git a/bin/provision.sh b/bin/provision.sh
index cc4f726..c155b56 100755
--- a/bin/provision.sh
+++ b/bin/provision.sh
@@ -13,12 +13,12 @@ fi
emerge-webrsync
emerge --metadata
-RUBIES="dev-lang/ruby:1.9 dev-lang/ruby:2.0 dev-lang/ruby:2.1 dev-lang/ruby:2.2"
+RUBIES=(dev-lang/ruby:1.9 dev-lang/ruby:2.0 dev-lang/ruby:2.1 dev-lang/ruby:2.2)
set +e
-emerge --pretend --quiet $RUBIES
+emerge --pretend --quiet "${RUBIES[@]}"
if [[ $? == 1 ]]; then
- emerge --autounmask-write $RUBIES
+ emerge --autounmask-write "${RUBIES[@]}"
etc-update --automode -5
fi
set -e
-emerge --noreplace --quiet $RUBIES
+emerge --noreplace --quiet "${RUBIES[@]}"
diff --git a/bin/repoman.sh b/bin/repoman.sh
index 923b8b2..32e9fc9 100755
--- a/bin/repoman.sh
+++ b/bin/repoman.sh
@@ -54,7 +54,7 @@ function CLEANUP() {
ENV_SETUP
-PKG_ARR=($(qatom $1))
+PKG_ARR=($(qatom "$1"))
CATEGORY="${PKG_ARR[0]}"
NAME="${PKG_ARR[1]}"
if [[ ${PKG_ARR[3]:=foo} == 'foo' ]]; then
@@ -63,7 +63,6 @@ else
VERSION="${PKG_ARR[2]}-${PKG_ARR[3]}"
fi
-PACKAGE=$1
CURR_TARGET=$2
NEXT_TARGET=$3
SETUP
diff --git a/bin/tinder.sh b/bin/tinder.sh
index 6d246f4..4c75533 100755
--- a/bin/tinder.sh
+++ b/bin/tinder.sh
@@ -33,11 +33,12 @@ function SETUP () {
cp "/usr/portage/$CATEGORY/$NAME/metadata.xml" "$SCRIPT_DIR/overlay/$CATEGORY/$NAME"
cp -r "/usr/portage/$CATEGORY/$NAME/files" "$SCRIPT_DIR/overlay/$CATEGORY/$NAME" || true
+ (
cd "$SCRIPT_DIR/overlay/$CATEGORY/$NAME"
sed -i -e "/^USE_RUBY/s/$CURR_TARGET/$CURR_TARGET $NEXT_TARGET/" "$NAME-$VERSION.ebuild"
repoman manifest
repoman full
- cd -
+ )
fi
set +e
@@ -97,7 +98,7 @@ function CLEANUP() {
ENV_SETUP
-PKG_ARR=($(qatom $1))
+PKG_ARR=($(qatom "$1"))
CATEGORY="${PKG_ARR[0]}"
NAME="${PKG_ARR[1]}"
if [[ ${PKG_ARR[3]:=foo} == "foo" ]]; then