aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-11-05 20:21:47 -0400
committerMike Frysinger <vapier@gentoo.org>2021-11-05 20:21:47 -0400
commit93db41e8d06902f3a6b75003df5e81f83846e500 (patch)
treec8533b4b0f978a335a7cf1b32d0953b8c4c8ee52
parentsandbox: move xasprintf helper here (diff)
downloadsandbox-93db41e8d06902f3a6b75003df5e81f83846e500.tar.gz
sandbox-93db41e8d06902f3a6b75003df5e81f83846e500.tar.bz2
sandbox-93db41e8d06902f3a6b75003df5e81f83846e500.zip
build: drop support for ancient C library versions
We don't need to support glibc versions that predate Linux-2.6. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--configure.ac12
-rw-r--r--localdecls.h13
2 files changed, 2 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index c1aa576..a353e0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,18 +307,6 @@ dnl uClibc doesn't currently provide dlvsym() so lets
dnl verify the toolchain supports it
AC_CHECK_FUNCS([dlvsym])
-dnl when using libc5, (f)trucate's offset argument type is size_t with
-dnl libc5, but it's off_t with libc6 (glibc2).
-AC_MSG_CHECKING([truncate argument type])
-AC_EGREP_HEADER([truncate.*size_t], [unistd.h],
- [dnl
- AC_MSG_RESULT([size_t])
- AC_DEFINE([TRUNCATE_T], [size_t], [truncate arg type])
- ],[dnl
- AC_MSG_RESULT([off_t])
- AC_DEFINE([TRUNCATE_T], [off_t], [truncate arg type])
-])
-
dnl Check if libc provides RTLD_NEXT
AC_MSG_CHECKING([for RTLD_NEXT])
AC_TRY_COMPILE([
diff --git a/localdecls.h b/localdecls.h
index ecc5856..6b727ff 100644
--- a/localdecls.h
+++ b/localdecls.h
@@ -11,9 +11,8 @@
/* take care of broken ld loading */
#if defined(__GLIBC__) && !defined(__UCLIBC__)
-# if __GLIBC__ <= 2 && __GLIBC_MINOR__ <= 2
-# define BROKEN_RTLD_NEXT
-# define LIBC 5
+# if __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ <= 2)
+# error "glibc-2.3+ required"
# endif
# if !defined(BROKEN_RTLD_NEXT)
@@ -22,14 +21,6 @@
# endif
# endif
-#else
-
-#if 0
-# if defined(__FreeBSD__)
-# define BROKEN_RTLD_NEXT
-# endif
-#endif
-
#endif
#ifdef PATH_MAX