aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-06-17 22:00:16 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-06-19 12:40:23 +0200
commit63b1dce345203efaf4415c609c935abdccc5e1da (patch)
tree76e47dabd6ac1f6e611a7d8b7431de0c67b82e57
parentsci-mathematics/pulp: tests pass with python3.12 (diff)
downloadsci-63b1dce345203efaf4415c609c935abdccc5e1da.tar.gz
sci-63b1dce345203efaf4415c609c935abdccc5e1da.tar.bz2
sci-63b1dce345203efaf4415c609c935abdccc5e1da.zip
dev-python/snakemake: version 7.32.4 is compat with py3.12
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Closes: https://github.com/gentoo/sci/pull/1278 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/snakemake/snakemake-7.32.4.ebuild4
-rw-r--r--dev-python/snakemake/snakemake-8.14.0.ebuild14
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/snakemake/snakemake-7.32.4.ebuild b/dev-python/snakemake/snakemake-7.32.4.ebuild
index 711aac286..8ff44fdb5 100644
--- a/dev-python/snakemake/snakemake-7.32.4.ebuild
+++ b/dev-python/snakemake/snakemake-7.32.4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -54,7 +54,7 @@ RDEPEND="
dev-python/toposort[${PYTHON_USEDEP}]
dev-python/wrapt[${PYTHON_USEDEP}]
dev-python/yte[${PYTHON_USEDEP}]
- sci-mathematics/pulp[${PYTHON_USEDEP}]
+ <sci-mathematics/pulp-2.8[${PYTHON_USEDEP}]
"
distutils_enable_sphinx docs \
diff --git a/dev-python/snakemake/snakemake-8.14.0.ebuild b/dev-python/snakemake/snakemake-8.14.0.ebuild
index 1c601d4fa..fed1a1bbb 100644
--- a/dev-python/snakemake/snakemake-8.14.0.ebuild
+++ b/dev-python/snakemake/snakemake-8.14.0.ebuild
@@ -64,11 +64,11 @@ RDEPEND="
sci-mathematics/pulp[${PYTHON_USEDEP}]
"
-distutils_enable_sphinx docs \
- dev-python/sphinxcontrib-napoleon \
- dev-python/sphinx-argparse \
- dev-python/sphinx-rtd-theme \
- dev-python/docutils \
- dev-python/recommonmark \
- dev-python/myst-parser
+# distutils_enable_sphinx docs \
+# dev-python/sphinxcontrib-napoleon \
+# dev-python/sphinx-argparse \
+# dev-python/sphinx-rtd-theme \
+# dev-python/docutils \
+# dev-python/recommonmark \
+# dev-python/myst-parser
distutils_enable_tests pytest