aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-05-07 22:06:23 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-06-27 14:20:28 +0200
commitc00c3966a7b556235042f75038aa7507a61e8063 (patch)
treedd62104d814320b12ea1faa0f9004ed752177dd2
parentsci-physics/mcfm: Adjust oneloop version (diff)
downloadsci-c00c3966a7b556235042f75038aa7507a61e8063.tar.gz
sci-c00c3966a7b556235042f75038aa7507a61e8063.tar.bz2
sci-c00c3966a7b556235042f75038aa7507a61e8063.zip
sci-physics/tauola: update EAPI 7 -> 8
Co-authored-by: Andrew Nowa Ammerlaan <andrewammerlaan@gentoo.org> Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/tauola/files/tauola-1.1.8-tau-spinner-makefile-install.patch22
-rw-r--r--sci-physics/tauola/metadata.xml13
-rw-r--r--sci-physics/tauola/tauola-1.1.8-r1.ebuild80
3 files changed, 113 insertions, 2 deletions
diff --git a/sci-physics/tauola/files/tauola-1.1.8-tau-spinner-makefile-install.patch b/sci-physics/tauola/files/tauola-1.1.8-tau-spinner-makefile-install.patch
new file mode 100644
index 000000000..2d93959c5
--- /dev/null
+++ b/sci-physics/tauola/files/tauola-1.1.8-tau-spinner-makefile-install.patch
@@ -0,0 +1,22 @@
+--- a/Makefile 2020-01-28 18:43:43.000000000 +0100
++++ b/Makefile 2024-05-07 21:51:01.306908458 +0200
+@@ -48,7 +48,7 @@
+ mkdir -p $(DESTDIR)/$(PREFIX)/include/Tauola
+ install -m 644 include/Tauola/* $(DESTDIR)/$(PREFIX)/include/Tauola/.
+ mkdir -p $(DESTDIR)/$(LIBDIR)
+- install lib/*so.$(LIB_VER) $(DESTDIR)/$(LIBDIR)/
++ install lib/*so.* $(DESTDIR)/$(LIBDIR)/
+ install lib/*a $(DESTDIR)/$(LIBDIR)/
+ cp -P lib/*so $(DESTDIR)/$(LIBDIR)/
+
+--- a/TauSpinner/Makefile 2024-05-07 21:57:58.542875180 +0200
++++ b/TauSpinner/Makefile 2024-05-07 21:58:42.993509785 +0200
+@@ -52,7 +52,7 @@
+
+ libTauSpinner: $(TAU_SPINNER_OBJECTS)
+ ar cr lib/$(LIB_TAU_SPINNER_A) $(TAU_SPINNER_OBJECTS)
+- $(LD) $(LDFLAGS) $(SOFLAGS) $(TAU_SPINNER_OBJECTS) -o lib/$(LIB_TAU_SPINNER_SO).$(LIB_VER)
++ $(LD) $(LDFLAGS) $(SOFLAGS) $(TAU_SPINNER_OBJECTS) -o lib/$(LIB_TAU_SPINNER_SO).$(LIB_VER) -Wl,-soname,$(LIB_TAU_SPINNER_SO)
+ ln -sf $(LIB_TAU_SPINNER_SO).$(LIB_VER) lib/$(LIB_TAU_SPINNER_SO)
+
+ clean:
diff --git a/sci-physics/tauola/metadata.xml b/sci-physics/tauola/metadata.xml
index b0f8228f8..fcbc9de77 100644
--- a/sci-physics/tauola/metadata.xml
+++ b/sci-physics/tauola/metadata.xml
@@ -2,14 +2,23 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>piatlicki@gmail.com</email>
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
</maintainer>
<maintainer type="project">
<email>sci-physics@gentoo.org</email>
<name>Gentoo Physics Project</name>
</maintainer>
+
+ <longdescription lang="en">
+ TAUOLA is a program that simulates the decays of polarized tau leptons, which are elementary particles that belong to the lepton family. Tau leptons are heavier than electrons and muons, and they can decay into various final states, such as hadrons, leptons, and neutrinos. TAUOLA can generate Monte Carlo events for tau lepton decays, taking into account the polarization, spin correlations, and radiative corrections. TAUOLA can also model anomalous and lepton flavor violating decays, which are beyond the standard model of particle physics.
+ </longdescription>
<use>
- <flag name="hepmc">Compile <pkg>sci-physics/hepmc</pkg> interface</flag>
+ <flag name="hepmc"> Compile with <pkg>sci-physics/hepmc</pkg> version 2 interface </flag>
+ <flag name="hepmc2"> Compile with <pkg>sci-physics/hepmc</pkg> version 2 interface </flag>
+ <flag name="hepmc3"> Compile with <pkg>sci-physics/hepmc</pkg> version 3 interface </flag>
+ <flag name="pythia"> Compile with <pkg>sci-physics/pythia</pkg> connection </flag>
+ <flag name="lhapdf"> Compile with <pkg>sci-physics/lhapdf</pkg> connection </flag>
<flag name="tau-spinner">Compile with TauSpinner library</flag>
</use>
</pkgmetadata>
diff --git a/sci-physics/tauola/tauola-1.1.8-r1.ebuild b/sci-physics/tauola/tauola-1.1.8-r1.ebuild
new file mode 100644
index 000000000..0e2b3fc3a
--- /dev/null
+++ b/sci-physics/tauola/tauola-1.1.8-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fortran-2
+
+MY_PN="TAUOLA"
+MY_P=${MY_PN}.${PV}
+
+DESCRIPTION="Tau decay Monte Carlo generator"
+HOMEPAGE="http://tauolapp.web.cern.ch/"
+SRC_URI="https://tauolapp.web.cern.ch/resources/${MY_P}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+hepmc3 +lhapdf doc examples hepmc2 pythia tau-spinner"
+REQUIRED_USE=" || ( hepmc2 hepmc3 ) tau-spinner? ( lhapdf )"
+
+RDEPEND="
+ hepmc2? ( sci-physics/hepmc:2=[-cm(-),gev(+)] )
+ hepmc3? ( sci-physics/hepmc:3=[-cm(-),gev(+)] )
+ pythia? ( sci-physics/pythia:8= )
+ lhapdf? ( sci-physics/lhapdf )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-text/doxygen[dot]
+ app-text/ghostscript-gpl
+ app-text/texlive
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.8-tau-spinner-makefile-install.patch
+)
+
+src_configure() {
+ econf \
+ $(use_with lhapdf) \
+ $(use_with tau-spinner) \
+ $(use_with pythia pythia8 "${EPREFIX}/usr") \
+ $(use_with hepmc2 hepmc "${EPREFIX}/usr") \
+ $(use_with hepmc3 hepmc3 "${EPREFIX}/usr") \
+ --without-mc-tester
+ # weird autoconf + Makefile
+ cat <<-EOF >> make.inc || die
+ LDFLAGS += ${LDFLAGS}
+ CFLAGS += ${CFLAGS}
+ FFLAGS += ${FFLAGS}
+ EOF
+}
+
+src_compile() {
+ emake -j1
+
+ if use doc; then
+ cd "${S}/documentation/doxy_documentation" || die
+ default
+ cd "${S}/documentation/latex_documentation" || die
+ default
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dodoc documentation/doxy_documentation/html/*
+ dodoc documentation/latex_documentation/*.pdf
+ fi
+
+ if use examples; then
+ dodoc -r examples
+ docinto tau-spinner && dodoc -r TauSpinner/examples
+ fi
+}