summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgnacio Arque-Latour (TS1k) <ts1k@telephreak.org>2007-11-07 12:15:58 +0000
committerIgnacio Arque-Latour (TS1k) <ts1k@telephreak.org>2007-11-07 12:15:58 +0000
commit1eaaa79f492648005de642b3d07c3a1afefc9d51 (patch)
tree34a4e87ce9696ccea5758c05419c6291bdf87aad /net-dialup/iwar/iwar-0.071.ebuild
parentmedia-radio/grig: Added 'coverage' and 'nohardware' USE flags (diff)
downloadsunrise-reviewed-1eaaa79f492648005de642b3d07c3a1afefc9d51.tar.gz
sunrise-reviewed-1eaaa79f492648005de642b3d07c3a1afefc9d51.tar.bz2
sunrise-reviewed-1eaaa79f492648005de642b3d07c3a1afefc9d51.zip
net-dialup/iwar: New Ebuild
svn path=/sunrise/; revision=4981
Diffstat (limited to 'net-dialup/iwar/iwar-0.071.ebuild')
-rw-r--r--net-dialup/iwar/iwar-0.071.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-dialup/iwar/iwar-0.071.ebuild b/net-dialup/iwar/iwar-0.071.ebuild
new file mode 100644
index 000000000..a2cf6bf0d
--- /dev/null
+++ b/net-dialup/iwar/iwar-0.071.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Intelligent Wardialer Program"
+HOMEPAGE="http://www.softwink.com/iwar"
+SRC_URI="http://softwink.com/iwar/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="iax2 mysql"
+
+DEPEND="sys-libs/ncurses
+mysql? ( dev-db/mysql )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_SOURCE="${FILESDIR}" EPATCH_SUFFIX="patch"
+ EPATCH_FORCE="yes" epatch
+}
+
+src_compile() {
+ econf $(use_enable mysql) \
+ $(use_enable iax2) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /etc/iwar
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog FAQ MODEMS-TESTED README README.IAX2 THANKS TODO
+ doman "${FILESDIR}"/${PN}.1
+}
+
+pkg_postinst() {
+ einfo "Users must be in group uucp in order to be able to use iwar."
+}