summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-03-29 00:12:10 +0000
committerhasufell <julian.ospald@googlemail.com>2012-03-29 00:12:10 +0000
commit0e73d5a4f7ff586e1790e7fafba9955e6c5f76d8 (patch)
tree7fb099806c7173938349892747d2fa4402bee353 /x11-misc
parentx11-misc/spacefm-dmenu-plugin: New Ebuild for bug 410083 thanks to xmw and fl... (diff)
downloadsunrise-reviewed-0e73d5a4f7ff586e1790e7fafba9955e6c5f76d8.tar.gz
sunrise-reviewed-0e73d5a4f7ff586e1790e7fafba9955e6c5f76d8.tar.bz2
sunrise-reviewed-0e73d5a4f7ff586e1790e7fafba9955e6c5f76d8.zip
x11-misc/spacefm-trash-plugin: New Ebuild for bug 410083 thanks to xmw and floppym
svn path=/sunrise/; revision=12856
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/spacefm-trash-plugin/ChangeLog10
-rw-r--r--x11-misc/spacefm-trash-plugin/Manifest4
-rw-r--r--x11-misc/spacefm-trash-plugin/metadata.xml7
-rw-r--r--x11-misc/spacefm-trash-plugin/spacefm-trash-plugin-0.5.ebuild41
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/spacefm-trash-plugin/ChangeLog b/x11-misc/spacefm-trash-plugin/ChangeLog
new file mode 100644
index 000000000..8451a4a27
--- /dev/null
+++ b/x11-misc/spacefm-trash-plugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/spacefm-trash-plugin
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*spacefm-trash-plugin-0.5 (29 Mar 2012)
+
+ 29 Mar 2012; hasufell <julian.ospald@googlemail.com>
+ +spacefm-trash-plugin-0.5.ebuild, +metadata.xml:
+ New Ebuild for bug 410083 thanks to xmw and floppym
+
diff --git a/x11-misc/spacefm-trash-plugin/Manifest b/x11-misc/spacefm-trash-plugin/Manifest
new file mode 100644
index 000000000..e7fd24e35
--- /dev/null
+++ b/x11-misc/spacefm-trash-plugin/Manifest
@@ -0,0 +1,4 @@
+DIST Trash_v0.5.spacefm-plugin.tar.gz 55786 RMD160 401aa77149b95ab215a37e4c2c2fb6bb4dceb9b6 SHA1 99b2200161af2314411951fa3b0207cf3dd7ffca SHA256 60b3f82be74811cb9fc22b4b37f57c136fb889eb897fde8b82eb1d53409ba54d
+EBUILD spacefm-trash-plugin-0.5.ebuild 1126 RMD160 6762820f4ca23485e9204b7d7fb5343d675fec89 SHA1 f0976f6c82b604fb67e4cce5959383bb59dd7d2a SHA256 80da11ce35a2dc2f9ff26fd1cf92275e6e38a69d9364d11e47f390f37f2a0ea5
+MISC ChangeLog 332 RMD160 6f955fe264a1c41fdd6ee67c2a9ecc5211377750 SHA1 21916b9cd878bfe360d39477dbd725225304df5e SHA256 6c6403c423960f4e0e52293a66080ac2fc214585c4f73edfada0c3fb50d9ec82
+MISC metadata.xml 214 RMD160 efd8175069efb91061298ff4584218b633e44678 SHA1 d372fdbfcb7fd07a4082961d3f3527be4fca1d60 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154
diff --git a/x11-misc/spacefm-trash-plugin/metadata.xml b/x11-misc/spacefm-trash-plugin/metadata.xml
new file mode 100644
index 000000000..cc3fe2494
--- /dev/null
+++ b/x11-misc/spacefm-trash-plugin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/spacefm-trash-plugin/spacefm-trash-plugin-0.5.ebuild b/x11-misc/spacefm-trash-plugin/spacefm-trash-plugin-0.5.ebuild
new file mode 100644
index 000000000..75b142dd5
--- /dev/null
+++ b/x11-misc/spacefm-trash-plugin/spacefm-trash-plugin-0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Adds trash-functionality to spacefm"
+HOMEPAGE="http://code.google.com/p/bashscripts/source/browse/trunk/spacefm-plugin/share-via-http-server/share-via-http-server"
+SRC_URI="http://bashscripts.googlecode.com/files/Trash_v${PV}.spacefm-plugin.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/spacefm"
+
+src_install() {
+ find -name COPYING -delete
+ insinto /usr/share/spacefm/plugins/trash
+ doins -r cstm_* plugin
+ insinto /usr/share/spacefm/plugin-files
+ doins "${DISTDIR}"/Trash_v${PV}.spacefm-plugin.tar.gz
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "You might need to restart spacefm for the changes to take effect."
+ einfo ""
+ elog "If you want to add a plugin to a different menu via design-mode"
+ elog "use the plugin-files from '/usr/share/spacefm/plugin-files'."
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo ""
+ elog "If you have copied the plugin to a different menu using the"
+ elog "design mode you might want to remove it from there as well."
+ einfo ""
+}
+