summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Schultz <mattsch@gmail.com>2012-11-27 15:55:44 -0600
committerMatthew Schultz <mattsch@gmail.com>2012-11-27 15:55:53 -0600
commit53b7cf37d1985c9e3a741fee32785ae12694e99a (patch)
treeef4e1f955a92ff3971adb3952e7f7cd7c31169d4 /app-text/sgml-base/sgml-base-1.26_p4.ebuild
parentAutomatic update to use.local.desc (diff)
downloadsunrise-53b7cf37d1985c9e3a741fee32785ae12694e99a.tar.gz
sunrise-53b7cf37d1985c9e3a741fee32785ae12694e99a.tar.bz2
sunrise-53b7cf37d1985c9e3a741fee32785ae12694e99a.zip
app-text/sgml-base: New Ebuild for bug #445004. Thanks to hasufell.
Diffstat (limited to 'app-text/sgml-base/sgml-base-1.26_p4.ebuild')
-rw-r--r--app-text/sgml-base/sgml-base-1.26_p4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/sgml-base/sgml-base-1.26_p4.ebuild b/app-text/sgml-base/sgml-base-1.26_p4.ebuild
new file mode 100644
index 000000000..b13df9f54
--- /dev/null
+++ b/app-text/sgml-base/sgml-base-1.26_p4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 2 '+')
+MY_PV=${MY_PV/p/nmu}
+
+DESCRIPTION="SGML infrastructure and SGML catalog file support"
+HOMEPAGE="http://packages.qa.debian.org/sgml-base"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ emake prefix="${D}"/usr install
+ dodoc README debian/{changelog,TODO}
+ newdoc debian/sgml-base.NEWS NEWS
+}