summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Hendrikx (whyscream) <tom@whyscream.net>2008-12-28 16:17:23 +0000
committerTom Hendrikx (whyscream) <tom@whyscream.net>2008-12-28 16:17:23 +0000
commit1ba05d6fb534221208e658438e50621c8f806ae0 (patch)
tree963e6af0778c7c3dd254cb580c94c6f1509ff83c /net-libs/ldns/ldns-1.4.1.ebuild
parentnet-analyzer/ArpON: Remove LICENSE file from dodoc (diff)
downloadsunrise-1ba05d6fb534221208e658438e50621c8f806ae0.tar.gz
sunrise-1ba05d6fb534221208e658438e50621c8f806ae0.tar.bz2
sunrise-1ba05d6fb534221208e658438e50621c8f806ae0.zip
net-libs/ldns: version bump
svn path=/sunrise/; revision=7550
Diffstat (limited to 'net-libs/ldns/ldns-1.4.1.ebuild')
-rw-r--r--net-libs/ldns/ldns-1.4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/ldns/ldns-1.4.1.ebuild b/net-libs/ldns/ldns-1.4.1.ebuild
new file mode 100644
index 000000000..b1ef76664
--- /dev/null
+++ b/net-libs/ldns/ldns-1.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/openssl"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changelog README || die "dodoc failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc for examples failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The drill binary and the ldns-* utilities were moved into their own"
+ ewarn "package. If you need them, install net-dns/ldns-utils."
+}