summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Borm (oli) <oli.borm@web.de>2007-11-02 17:22:58 +0000
committerOliver Borm (oli) <oli.borm@web.de>2007-11-02 17:22:58 +0000
commit4b42a3b2cdc7ebcac4738e6713ca20f61e7d9434 (patch)
tree61c34bb6c60f752561ef9f79b10bec7a2623a329 /net-misc/mico
parentk, so this isn't what sunrise should be used for, sry. thx jokey for telling me. (diff)
downloadsunrise-4b42a3b2cdc7ebcac4738e6713ca20f61e7d9434.tar.gz
sunrise-4b42a3b2cdc7ebcac4738e6713ca20f61e7d9434.tar.bz2
sunrise-4b42a3b2cdc7ebcac4738e6713ca20f61e7d9434.zip
net-misc/mico: Ebuild for bug 122141; Need mico for the soon coming OpenFOAM ebuild; Asked for that in gentoo-sunrise irc.
svn path=/sunrise/; revision=4942
Diffstat (limited to 'net-misc/mico')
-rw-r--r--net-misc/mico/ChangeLog9
-rw-r--r--net-misc/mico/Manifest4
-rw-r--r--net-misc/mico/metadata.xml5
-rw-r--r--net-misc/mico/mico-2.3.12.ebuild61
4 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/mico/ChangeLog b/net-misc/mico/ChangeLog
new file mode 100644
index 000000000..7a4b9016d
--- /dev/null
+++ b/net-misc/mico/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/mico
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 02 Nov 2007; Oliver Borm (boroli) <oli.borm@web.de> +metadata.xml,
+ +mico-2.3.12.ebuild:
+ Ebuild for bug 122141; Need mico for the soon coming OpenFOAM ebuild; Asked
+ for that in gentoo-sunrise irc.
+
diff --git a/net-misc/mico/Manifest b/net-misc/mico/Manifest
new file mode 100644
index 000000000..adad00910
--- /dev/null
+++ b/net-misc/mico/Manifest
@@ -0,0 +1,4 @@
+DIST mico-2.3.12.tar.gz 2837502 RMD160 2f45ace5044233f171ac8e4fd389d523befaca51 SHA1 e1885362d559ea97c62a2437a1d3a94114ef5b05 SHA256 f67663962c0fabfb459e0c14027fcd3ab9d809ba69cabdf9399abe467b9bbf4f
+EBUILD mico-2.3.12.ebuild 1752 RMD160 62c1e21e677853cf37f0bfb6c85bd123a9cc7e54 SHA1 09d73def1862f91548f3ae57e8361dce0ee646d6 SHA256 b4e9c55454dc03080c81174c90706f0660f7a664608ec336aa2dba87fadca57d
+MISC ChangeLog 319 RMD160 37ec724648582dd25c6204e47857f365fe81101a SHA1 dc45489380ea734ea2bfa1e0252d544e232926dd SHA256 fb8b7cba06c00ddec49f9a19dda26733ff80051d9ee19aa93eabb5a55d6f7398
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-misc/mico/metadata.xml b/net-misc/mico/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/net-misc/mico/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/net-misc/mico/mico-2.3.12.ebuild b/net-misc/mico/mico-2.3.12.ebuild
new file mode 100644
index 000000000..a2d680884
--- /dev/null
+++ b/net-misc/mico/mico-2.3.12.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.11-r1.ebuild,v 1.1 2005/08/04 20:33:58 azarah Exp $
+
+inherit eutils
+
+IUSE="ssl tcl gtk postgres threads" # qt3
+
+DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
+HOMEPAGE="http://www.mico.org/"
+SRC_URI="http://www.mico.org/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=sys-devel/flex-2.5.2
+ >=sys-devel/bison-1.22
+ ssl? ( dev-libs/openssl )
+ tcl? ( dev-lang/tcl )
+ postgres? ( dev-db/postgresql )"
+# qt3? ( x11-libs/qt )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ local myopts="--enable-final
+ --disable-mini-stl"
+# --enable-life
+# --enable-externalize"
+
+ if ! use threads; then
+ myopts="${myopts} --enable-threads=no --enable-pthreads=no"
+ fi
+
+ use ssl && myopts="${myopts} --with-ssl=/usr" \
+ || myopts="${myopts} --without-ssl"
+ use tcl && myopts="${myopts} --with-tcl=/usr" \
+ || myopts="${myopts} --without-tcl"
+# use qt3 && myopts="${myopts} --with-qt=${QTDIR}" \
+# || myopts="${myopts} --without-qt"
+ use gtk && myopts="${myopts} --with-gtk=/usr" \
+ || myopts="${myopts} --without-gtk"
+ use postgres && myopts="${myopts} --with-pgsql=/usr" \
+ || myopts="${myopts} --without-pgsql"
+
+ econf ${myopts} || die "configure failed"
+
+ # Rather not emake here, as is a memory hog
+ make || die "make failed"
+}
+
+src_install() {
+ emake INSTDIR="${D}"/usr SHARED_INSTDIR="${D}"/usr install || die
+
+ dodir /usr/share/
+ mv "${D}"/usr/man "${D}"/usr/share
+ dodir /usr/share/doc/
+ mv "${D}"/usr/doc "${D}"/usr/share/doc/"${P}"
+
+ dodoc CHANGES* CONVERT FAQ INSTALL* LICENSE* MANIFEST README* ROADMAP TODO VERSION
+}