summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorP. Levine <plevine457@verizon.net>2009-08-06 00:53:08 +0000
committerP. Levine <plevine457@verizon.net>2009-08-06 00:53:08 +0000
commit628c18b7c7b697b0b47ac6475dc4c306bc39bd76 (patch)
treec8484eb14886daf02004f320b07db7749b869c18 /sys-fs
parentapp-misc/navit: added --disable-svg2png, removed the version of the cegui dep... (diff)
downloadsunrise-628c18b7c7b697b0b47ac6475dc4c306bc39bd76.tar.gz
sunrise-628c18b7c7b697b0b47ac6475dc4c306bc39bd76.tar.bz2
sunrise-628c18b7c7b697b0b47ac6475dc4c306bc39bd76.zip
sys-fs/ntfs3g-ar: Fixups for pipe statements, fuse dependencies, and use flag handling.
svn path=/sunrise/; revision=8964
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g-ar/ChangeLog4
-rw-r--r--sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild15
2 files changed, 11 insertions, 8 deletions
diff --git a/sys-fs/ntfs3g-ar/ChangeLog b/sys-fs/ntfs3g-ar/ChangeLog
index 1b8d15ed7..c96566a32 100644
--- a/sys-fs/ntfs3g-ar/ChangeLog
+++ b/sys-fs/ntfs3g-ar/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Aug 2009; P. Levine <plevine457@verizon.net>
+ ntfs3g-ar-2009.4.4_pre16.ebuild:
+ Fixups for pipe statements, fuse dependencies, and use flag handling.
+
04 Aug 2009; P. Levine <plevine457@verizon.net>
+ntfs3g-ar-2009.4.4_pre16.ebuild, +files/10-ntfs3g.fdi.2009,
+metadata.xml:
diff --git a/sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild b/sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild
index a47c0b1f4..dac8fd2d8 100644
--- a/sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild
+++ b/sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild
@@ -17,12 +17,11 @@ IUSE="debug hal suid"
[[ ${KERNEL} == "linux" ]] && IUSE="${IUSE} fuse"
-RDEPEND="hal? ( sys-apps/hal )"
-
-DEPEND="${RDEPEND}
- !sys-fs/ntfs3g
+RDEPEND="hal? ( sys-apps/hal )
!kernel_linux? ( sys-fs/fuse )
- fuse? ( sys-fs/fuse )"
+ kernel_linux? ( fuse? ( sys-fs/fuse ) )"
+
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -38,7 +37,7 @@ pkg_setup() {
src_compile() {
local myconf
- use fuse && myconf="--with-fuse=external"
+ use kernel_linux && use fuse && myconf="--with-fuse=external"
econf \
--docdir="/usr/share/doc/${PF}" \
@@ -55,7 +54,7 @@ src_install() {
prepalldocs || die "prepalldocs failed"
dodoc AUTHORS ChangeLog CREDITS || die "dodoc failed"
- use suid && fperms u+s "/bin/${MY_PN}" || die "could not chage file permisions"
+ use suid && { fperms u+s "/bin/${PN/3g-ar/-3g}" || die "could not change file permisions"; }
if use hal; then
insinto /etc/hal/fdi/policy/
@@ -71,7 +70,7 @@ pkg_postinst() {
ewarn "http://pagesperso-orange.fr/b.andre/advanced-ntfs-3g.html"
ewarn
- if use fuse || ! use kernel_linux ; then
+ if ! use kernel_linux || use kernel_linux && use fuse ; then
ewarn
ewarn "ntfs-3g has been built with external FUSE support."
ewarn "If your system's FUSE package gets updated please rebuild ntfs-3g,"