summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/path/path-2.2.ebuild')
-rw-r--r--dev-python/path/path-2.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/path/path-2.2.ebuild b/dev-python/path/path-2.2.ebuild
new file mode 100644
index 000000000..33c7d6f90
--- /dev/null
+++ b/dev-python/path/path-2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Helpful python wrapper to the os.path module"
+HOMEPAGE="http://www.jorendorff.com/articles/python/path"
+SRC_URI="http://www.jorendorff.com/articles/python/${PN}/${P}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_test() {
+ ${python} test_path.py || die "test failed"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't install test_path.py
+ sed -i \
+ -e "s/, 'test_path'//" \
+ setup.py || die "sed failed"
+}
+