summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/alberta/alberta-1.2.1.ebuild')
-rw-r--r--sci-mathematics/alberta/alberta-1.2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/alberta/alberta-1.2.1.ebuild b/sci-mathematics/alberta/alberta-1.2.1.ebuild
new file mode 100644
index 000000000..63209a664
--- /dev/null
+++ b/sci-mathematics/alberta/alberta-1.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="An adaptive hierarchical finite element toolbox"
+HOMEPAGE="http://www.alberta-fem.de/"
+SRC_URI="http://www.alberta-fem.de/Downloads/${P/.1}.tar.gz
+ http://gentooexperimental.org/~genstef/dist/${P}.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sci-libs/blas-atlas
+ virtual/opengl"
+
+S="${WORKDIR}/${P/.1}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # A working version of the 1.2.1 patch provided by upstream
+ epatch "${WORKDIR}/${P}.patch"
+}
+
+src_compile() {
+ # There exists no ebuild for gltools nor grape, disabling it
+ econf \
+ --without-gltools \
+ --without-grape || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README THANKS AUTHORS NEWS
+}
+
+