summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/mlocate/mlocate-0.17.ebuild')
-rw-r--r--sys-apps/mlocate/mlocate-0.17.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-apps/mlocate/mlocate-0.17.ebuild b/sys-apps/mlocate/mlocate-0.17.ebuild
index 07c5bbba2..5371e6086 100644
--- a/sys-apps/mlocate/mlocate-0.17.ebuild
+++ b/sys-apps/mlocate/mlocate-0.17.ebuild
@@ -45,6 +45,14 @@ src_install() {
keepdir /var/lib/mlocate
}
+src_test() {
+ if has userpriv ${FEATURES}; then
+ make check-local ||die "test suite failed"
+ else
+ ewarn "Activate FEATURES=userpriv to run testsuite."
+ fi
+}
+
pkg_postinst() {
elog "Note that the /etc/updatedb.conf file is generic"
elog "Please customize it to your system requirements"