summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-07-05 11:09:06 +0000
committerMike Frysinger <vapier@gentoo.org>2010-07-05 11:09:06 +0000
commit8682d600899ee404321b66db2b6e0a71e47033bf (patch)
treee0d7337d774ea706165afe4f74e00673024f5290 /sys-devel/gcc/gcc-4.2.1.ebuild
parentFix installation of gdb auto-load modules. (diff)
downloadtoolchain-8682d600899ee404321b66db2b6e0a71e47033bf.tar.gz
toolchain-8682d600899ee404321b66db2b6e0a71e47033bf.tar.bz2
toolchain-8682d600899ee404321b66db2b6e0a71e47033bf.zip
import some older versions of gcc
Diffstat (limited to 'sys-devel/gcc/gcc-4.2.1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.2.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.2.1.ebuild b/sys-devel/gcc/gcc-4.2.1.ebuild
new file mode 100644
index 0000000..0f769c3
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/Attic/gcc-4.2.1.ebuild,v 1.3 2008/04/18 18:47:51 vapier dead $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+ETYPE="gcc-compiler"
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc -ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd" #ppc64: 179218
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/gcc-config-1.4
+ virtual/libiconv
+ fortran? (
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.2.0_p10
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/autogen dev-util/dejagnu )
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND=">=sys-devel/gcc-config-1.4"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
+}