summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-06-01 03:19:44 -0400
committerMike Frysinger <vapier@gentoo.org>2015-06-01 03:19:44 -0400
commitbc059ddc26d33a135b3536265f6c0de31fbd7334 (patch)
tree38dd695c7b8c2ff41afd1f3ff5e94513306673c7 /sys-devel/gcc/gcc-4.8.4_pre9999.ebuild
parentgcc: bump all ebuilds to at least EAPI=2 (diff)
downloadtoolchain-bc059ddc26d33a135b3536265f6c0de31fbd7334.tar.gz
toolchain-bc059ddc26d33a135b3536265f6c0de31fbd7334.tar.bz2
toolchain-bc059ddc26d33a135b3536265f6c0de31fbd7334.zip
gcc: move USE=debug handling to the eclass
Diffstat (limited to 'sys-devel/gcc/gcc-4.8.4_pre9999.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.8.4_pre9999.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/sys-devel/gcc/gcc-4.8.4_pre9999.ebuild b/sys-devel/gcc/gcc-4.8.4_pre9999.ebuild
index 30ad6e3..310702b 100644
--- a/sys-devel/gcc/gcc-4.8.4_pre9999.ebuild
+++ b/sys-devel/gcc/gcc-4.8.4_pre9999.ebuild
@@ -11,7 +11,7 @@ inherit multilib toolchain
KEYWORDS=""
SLOT="${GCC_BRANCH_VER}-vcs"
-IUSE="debug nobootstrap offline"
+IUSE="nobootstrap offline"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -45,8 +45,6 @@ src_prepare() {
[[ ${CHOST} == ${CTARGET} ]] && epatch "${GCC_FILESDIR}"/gcc-spec-env-r1.patch
fi
- use debug && GCC_CHECKS_LIST="yes"
-
# single-stage build for quick patch testing
if use nobootstrap; then
GCC_MAKE_TARGET="all"