summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-28 04:10:51 -0400
committerMike Frysinger <vapier@gentoo.org>2015-03-28 04:10:51 -0400
commite0e6af2786870012ba187cfc5673c45cbe43aefa (patch)
tree9582004eb583bac4843549b8a36e27bd532c4cb6 /sys-devel/gcc/gcc-4.9.0_alpha20150225.ebuild
parentgdb: update snapshots (diff)
downloadtoolchain-e0e6af2786870012ba187cfc5673c45cbe43aefa.tar.gz
toolchain-e0e6af2786870012ba187cfc5673c45cbe43aefa.tar.bz2
toolchain-e0e6af2786870012ba187cfc5673c45cbe43aefa.zip
gcc: update snapshots
Diffstat (limited to 'sys-devel/gcc/gcc-4.9.0_alpha20150225.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.9.0_alpha20150225.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.9.0_alpha20150225.ebuild b/sys-devel/gcc/gcc-4.9.0_alpha20150225.ebuild
new file mode 100644
index 0000000..d64a0c6
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.9.0_alpha20150225.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCC_FILESDIR="${PORTDIR}/sys-devel/gcc/files"
+
+inherit eutils toolchain
+
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
+ >=${CATEGORY}/binutils-2.18"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.12 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+
+ use debug && GCC_CHECKS_LIST="yes"
+}