summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-06-01 02:24:47 -0400
committerMike Frysinger <vapier@gentoo.org>2015-06-01 02:24:47 -0400
commita67bc69a8c69eadd151530b5268c79ef2944fb0c (patch)
tree2899aa527489063832bbe4c6d4b021815b1c3cbd /sys-devel/gcc/gcc-6.0.0_alpha20150531.ebuild
parentcache: regen (diff)
downloadtoolchain-a67bc69a8c69eadd151530b5268c79ef2944fb0c.tar.gz
toolchain-a67bc69a8c69eadd151530b5268c79ef2944fb0c.tar.bz2
toolchain-a67bc69a8c69eadd151530b5268c79ef2944fb0c.zip
gcc: update snapshots
Diffstat (limited to 'sys-devel/gcc/gcc-6.0.0_alpha20150531.ebuild')
-rw-r--r--sys-devel/gcc/gcc-6.0.0_alpha20150531.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-6.0.0_alpha20150531.ebuild b/sys-devel/gcc/gcc-6.0.0_alpha20150531.ebuild
new file mode 100644
index 0000000..428cd6b
--- /dev/null
+++ b/sys-devel/gcc/gcc-6.0.0_alpha20150531.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCC_FILESDIR="${PORTDIR}/sys-devel/gcc/files"
+
+inherit eutils toolchain
+
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.12 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+
+ use debug && GCC_CHECKS_LIST="yes"
+}