summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-05-13 11:51:31 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-05-13 11:51:56 +0300
commit5cf00cd5c6760d2c32640fe4e1e329c1808a0ae8 (patch)
treed09b133fa123488519160c6be4bd9e6f11f66566
parentRemove patches that only affect support files (diff)
downloadglibc-patches-5cf00cd5c6760d2c32640fe4e1e329c1808a0ae8.tar.gz
glibc-patches-5cf00cd5c6760d2c32640fe4e1e329c1808a0ae8.tar.bz2
glibc-patches-5cf00cd5c6760d2c32640fe4e1e329c1808a0ae8.zip
Drop sandbox-specific fixes; consolidate patches
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--9999/0001-Disable-ldconfig-during-install.patch (renamed from 9999/0001-Gentoo-disable-ldconfig-during-install.patch)6
-rw-r--r--9999/0002-Gentoo-support-running-tests-under-sandbox.patch67
-rw-r--r--9999/0002-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch (renamed from 9999/0004-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch)24
-rw-r--r--9999/0003-Adapt-to-Gentoo-specific-etc-mail-aliases.patch (renamed from 9999/0010-Gentoo-Adapt-tests-to-etc-mail-alias-location.patch)33
-rw-r--r--9999/0004-Add-C.UTF-8-locale.patch (renamed from 9999/0008-Gentoo-Add-a-C.UTF-8-locale.patch)4
-rw-r--r--9999/0005-Force-O0-in-conform-tests-to-survive-CC-changes.patch (renamed from 9999/0009-Gentoo-force-O0-in-conform-tests-to-survive-CC-chang.patch)5
-rw-r--r--9999/0005-Gentoo-disable-tests-that-fail-only-in-sandbox.patch144
-rw-r--r--9999/0006-Gentoo-Disable-test-that-fails-because-of-the-gethos.patch25
-rw-r--r--9999/0007-Gentoo-Adapt-to-Gentoo-specific-etc-mail-aliases.patch32
9 files changed, 51 insertions, 289 deletions
diff --git a/9999/0001-Gentoo-disable-ldconfig-during-install.patch b/9999/0001-Disable-ldconfig-during-install.patch
index c5595aa..0dbdd9a 100644
--- a/9999/0001-Gentoo-disable-ldconfig-during-install.patch
+++ b/9999/0001-Disable-ldconfig-during-install.patch
@@ -1,7 +1,7 @@
-From c42be799cdc293c6f454e26124f30f87d9bb69a9 Mon Sep 17 00:00:00 2001
+From 8831dc046682b2f3fca8a0dc831e53afdebd4469 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Wed, 1 Apr 2009 02:15:48 -0400
-Subject: [PATCH 01/12] Gentoo: disable ldconfig during install
+Subject: [PATCH 1/5] Disable ldconfig during install
Do not bother running ldconfig on DESTDIR. It's a waste of time as we
won't use the result (portage will rebuild the cache after install).
@@ -15,7 +15,7 @@ https://bugs.gentoo.org/431038
1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile
-index 8f0a93aceb..7c3887d5c4 100644
+index 6dcfe40c25..68259babda 100644
--- a/Makefile
+++ b/Makefile
@@ -116,6 +116,7 @@ install-symbolic-link: subdir_install
diff --git a/9999/0002-Gentoo-support-running-tests-under-sandbox.patch b/9999/0002-Gentoo-support-running-tests-under-sandbox.patch
deleted file mode 100644
index 1bc7be2..0000000
--- a/9999/0002-Gentoo-support-running-tests-under-sandbox.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From a4ec232302f8b30f6fc7eb7a53aadf99b3fad312 Mon Sep 17 00:00:00 2001
-From: "Stephanie J. Lockwood-Childs" <wormo@gentoo.org>
-Date: Tue, 13 Mar 2007 01:57:21 -0400
-Subject: [PATCH 02/12] Gentoo: support running tests under sandbox
-
-when glibc runs its tests, it does so by invoking the local library loader.
-in Gentoo, we build/run inside of our "sandbox" which itself is linked against
-libdl (so that it can load libraries and pull out symbols). the trouble
-is that when you upgrade from an older glibc to the new one, often times
-internal symbols change name or abi. this is normally OK as you cannot use
-libc.so from say version 2.3.6 but libpthread.so from say version 2.5, so
-we always say "keep all of the glibc libraries from the same build". but
-when glibc runs its tests, it uses dynamic paths to point to its new local
-copies of libraries. if the test doesnt use libdl, then glibc doesnt add
-its path, and when sandbox triggers the loading of libdl, glibc does so
-from the host system system. this gets us into the case of all libraries
-are from the locally compiled version of glibc except for libdl.so.
-
-http://bugs.gentoo.org/56898
----
- Makeconfig | 2 +-
- iconvdata/run-iconv-test.sh | 2 +-
- nptl/tst-tls6.sh | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makeconfig b/Makeconfig
-index f252842979..5076902c87 100644
---- a/Makeconfig
-+++ b/Makeconfig
-@@ -728,7 +728,7 @@ comma = ,
- sysdep-library-path = \
- $(subst $(empty) ,:,$(strip $(patsubst -Wl$(comma)-rpath-link=%, %,\
- $(filter -Wl$(comma)-rpath-link=%,\
-- $(sysdep-LDFLAGS)))))
-+ $(sysdep-LDFLAGS)))) $(common-objpfx)/dlfcn)
- # $(run-via-rtld-prefix) is a command that, when prepended to the name
- # of a program built with the newly built library, produces a command
- # that, executed on the host for which the library is built, runs that
-diff --git a/iconvdata/run-iconv-test.sh b/iconvdata/run-iconv-test.sh
-index 56b6630a6d..be74dbf302 100755
---- a/iconvdata/run-iconv-test.sh
-+++ b/iconvdata/run-iconv-test.sh
-@@ -31,7 +31,7 @@ temp2=$codir/iconvdata/iconv-test.yyy
- trap "rm -f $temp1 $temp2" 1 2 3 15
-
- # We have to have some directories in the library path.
--LIBPATH=$codir:$codir/iconvdata
-+LIBPATH=$codir:$codir/iconvdata:$codir/dlfcn
-
- # How the start the iconv(1) program.
- ICONV='$codir/elf/ld.so --library-path $LIBPATH --inhibit-rpath ${from}.so \
-diff --git a/nptl/tst-tls6.sh b/nptl/tst-tls6.sh
-index e6dc20572a..a25b167b2d 100755
---- a/nptl/tst-tls6.sh
-+++ b/nptl/tst-tls6.sh
-@@ -26,7 +26,7 @@ run_program_env=$1; shift
- logfile=$common_objpfx/nptl/tst-tls6.out
-
- # We have to find libc and nptl
--library_path=${common_objpfx}:${common_objpfx}nptl
-+library_path=${common_objpfx}:${common_objpfx}nptl:${common_objpfx}/dlfcn
- tst_tls5="${test_via_rtld_prefix} ${common_objpfx}/nptl/tst-tls5"
-
- > $logfile
---
-2.26.2
-
diff --git a/9999/0004-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch b/9999/0002-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch
index 4002a64..5604d9f 100644
--- a/9999/0004-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch
+++ b/9999/0002-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch
@@ -1,8 +1,8 @@
-From 493fd65c116f423e9bb0a374314775fd475575c3 Mon Sep 17 00:00:00 2001
+From cc789d18e5f6bb39ecca6ee8ec2872bd7a737160 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
Date: Tue, 29 Aug 2017 22:58:50 +0200
-Subject: [PATCH 04/12] Revert " * sysdeps/posix/getaddrinfo.c (gaih_inet):
- Only use gethostbyname4_r"
+Subject: [PATCH 2/5] Revert " * sysdeps/posix/getaddrinfo.c (gaih_inet): Only
+ use gethostbyname4_r"
This reverts commit 8479f23aa1d5e5477a37f46823856bdafaedfa46.
@@ -10,12 +10,24 @@ See for the background
https://sourceware.org/bugzilla/show_bug.cgi?id=16826
https://bugs.gentoo.org/show_bug.cgi?id=600632
-This makes test resolv/tst-res_use_inet6 fail. Disable it.
-(cherry picked from commit 06a2a073a2c6fb3e1489af96e125daca248d0a03)
+This makes tst-nss-files-hosts-multi fail. Disable it.
---
+ nss/Makefile | 1 -
sysdeps/posix/getaddrinfo.c | 9 ++-------
- 1 file changed, 2 insertions(+), 7 deletions(-)
+ 2 files changed, 2 insertions(+), 8 deletions(-)
+diff --git a/nss/Makefile b/nss/Makefile
+index 97bab5bb75..7a6ddebde2 100644
+--- a/nss/Makefile
++++ b/nss/Makefile
+@@ -68,7 +68,6 @@ tests-container = \
+ # Tests which need libdl
+ ifeq (yes,$(build-shared))
+ tests += tst-nss-files-hosts-erange
+-tests += tst-nss-files-hosts-multi
+ tests += tst-nss-files-hosts-getent
+ tests += tst-nss-files-alias-leak
+ tests += tst-nss-files-alias-truncated
diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
index ed04e564f9..ce9e0d342d 100644
--- a/sysdeps/posix/getaddrinfo.c
diff --git a/9999/0010-Gentoo-Adapt-tests-to-etc-mail-alias-location.patch b/9999/0003-Adapt-to-Gentoo-specific-etc-mail-aliases.patch
index bcf87ab..13ff145 100644
--- a/9999/0010-Gentoo-Adapt-tests-to-etc-mail-alias-location.patch
+++ b/9999/0003-Adapt-to-Gentoo-specific-etc-mail-aliases.patch
@@ -1,15 +1,34 @@
-From 96f7387cdee162005d2373cbdcd1f7b65dfccd2c Mon Sep 17 00:00:00 2001
-From: "Andreas K. Huettel" <dilfridge@gentoo.org>
-Date: Sat, 21 Mar 2020 15:54:14 +0100
-Subject: [PATCH 10/12] Gentoo: Adapt tests to /etc/mail/alias location
+From dbe134e9eed77bfbbbbf80fa97f2b02b869bcf9c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Mon, 22 Oct 2018 22:34:13 +0200
+Subject: [PATCH 3/5] Adapt to Gentoo-specific /etc/mail/aliases
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
-Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
-(cherry picked from commit 03fb405d759b9806fa150813f04dfe1aaa658ac6)
+Patch by pacho2
+
+Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
+(cherry picked from commit 4e616cda056f471b799beba2b1cedc787ad4ecc0)
---
+ nss/nss_files/files-alias.c | 2 +-
nss/tst-nss-files-alias-leak.c | 18 +++++++++---------
support/support_chroot.c | 8 +++++++-
- 2 files changed, 16 insertions(+), 10 deletions(-)
+ 3 files changed, 17 insertions(+), 11 deletions(-)
+diff --git a/nss/nss_files/files-alias.c b/nss/nss_files/files-alias.c
+index 6aff7b4c10..bb6d9b5765 100644
+--- a/nss/nss_files/files-alias.c
++++ b/nss/nss_files/files-alias.c
+@@ -49,7 +49,7 @@ internal_setent (FILE **stream)
+
+ if (*stream == NULL)
+ {
+- *stream = fopen ("/etc/aliases", "rce");
++ *stream = fopen ("/etc/mail/aliases", "rce");
+
+ if (*stream == NULL)
+ status = errno == EAGAIN ? NSS_STATUS_TRYAGAIN : NSS_STATUS_UNAVAIL;
diff --git a/nss/tst-nss-files-alias-leak.c b/nss/tst-nss-files-alias-leak.c
index daebbf4ed4..095bb753a6 100644
--- a/nss/tst-nss-files-alias-leak.c
diff --git a/9999/0008-Gentoo-Add-a-C.UTF-8-locale.patch b/9999/0004-Add-C.UTF-8-locale.patch
index 31903b6..deea332 100644
--- a/9999/0008-Gentoo-Add-a-C.UTF-8-locale.patch
+++ b/9999/0004-Add-C.UTF-8-locale.patch
@@ -1,7 +1,7 @@
-From baeb7948ba8b6cc25059cf9659d045e24cd7d879 Mon Sep 17 00:00:00 2001
+From 776636b6940ed6f3e08b0a67c290f241885384cb Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Mon, 10 Aug 2015 15:58:12 +0200
-Subject: [PATCH 08/12] Gentoo: Add a C.UTF-8 locale
+Subject: [PATCH 4/5] Add C.UTF-8 locale
Source:
https://src.fedoraproject.org/rpms/glibc/raw/master/f/glibc-c-utf8-locale.patch
diff --git a/9999/0009-Gentoo-force-O0-in-conform-tests-to-survive-CC-chang.patch b/9999/0005-Force-O0-in-conform-tests-to-survive-CC-changes.patch
index 9504792..02532cd 100644
--- a/9999/0009-Gentoo-force-O0-in-conform-tests-to-survive-CC-chang.patch
+++ b/9999/0005-Force-O0-in-conform-tests-to-survive-CC-changes.patch
@@ -1,8 +1,7 @@
-From 1c39b1dd8ad727a48cb3c9fbcd9d005f690752eb Mon Sep 17 00:00:00 2001
+From 84d03a910e28bb804453dad3e7600afe5e70256d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
Date: Fri, 14 Dec 2018 20:43:04 +0100
-Subject: [PATCH 09/12] Gentoo: force -O0 in conform tests to survive $CC
- changes
+Subject: [PATCH 5/5] Force -O0 in conform tests to survive $CC changes
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
diff --git a/9999/0005-Gentoo-disable-tests-that-fail-only-in-sandbox.patch b/9999/0005-Gentoo-disable-tests-that-fail-only-in-sandbox.patch
deleted file mode 100644
index f0b00a5..0000000
--- a/9999/0005-Gentoo-disable-tests-that-fail-only-in-sandbox.patch
+++ /dev/null
@@ -1,144 +0,0 @@
-From 8c012e90bf4645d37cb022d273d814b3fbc33a94 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
-Date: Mon, 11 Sep 2017 13:14:46 +0200
-Subject: [PATCH 05/12] Gentoo: disable tests that fail only in sandbox
-
----
- elf/Makefile | 16 +---------------
- io/Makefile | 2 +-
- nptl/Makefile | 7 +++++--
- posix/Makefile | 4 ++--
- resolv/Makefile | 2 --
- sysdeps/unix/sysv/linux/Makefile | 2 +-
- 6 files changed, 10 insertions(+), 23 deletions(-)
-
-diff --git a/elf/Makefile b/elf/Makefile
-index da689a2c7b..dcf29d47b9 100644
---- a/elf/Makefile
-+++ b/elf/Makefile
-@@ -413,8 +413,7 @@ tests-special += $(objpfx)order-cmp.out $(objpfx)tst-array1-cmp.out \
- $(objpfx)tst-array4-cmp.out $(objpfx)tst-array5-cmp.out \
- $(objpfx)tst-array5-static-cmp.out $(objpfx)order2-cmp.out \
- $(objpfx)tst-initorder-cmp.out \
-- $(objpfx)tst-initorder2-cmp.out $(objpfx)tst-unused-dep.out \
-- $(objpfx)tst-unused-dep-cmp.out
-+ $(objpfx)tst-initorder2-cmp.out
- endif
-
- check-abi: $(objpfx)check-abi-ld.out
-@@ -1461,19 +1460,6 @@ $(objpfx)tst-relsort1mod2.so: $(libm)
- $(objpfx)tst-relsort1.out: $(objpfx)tst-relsort1mod1.so \
- $(objpfx)tst-relsort1mod2.so
-
--$(objpfx)tst-unused-dep.out: $(objpfx)testobj1.so
-- $(test-wrapper-env) \
-- LD_TRACE_LOADED_OBJECTS=1 \
-- LD_DEBUG=unused \
-- LD_PRELOAD= \
-- $(rtld-prefix) \
-- $< > $@; \
-- $(evaluate-test)
--
--$(objpfx)tst-unused-dep-cmp.out: $(objpfx)tst-unused-dep.out
-- cmp $< /dev/null > $@; \
-- $(evaluate-test)
--
- $(objpfx)tst-audit11.out: $(objpfx)tst-auditmod11.so $(objpfx)tst-audit11mod1.so
- $(objpfx)tst-audit11: $(libdl)
- tst-audit11-ENV = LD_AUDIT=$(objpfx)tst-auditmod11.so
-diff --git a/io/Makefile b/io/Makefile
-index cf380f3516..b6fe301f77 100644
---- a/io/Makefile
-+++ b/io/Makefile
-@@ -73,7 +73,7 @@ tests := test-utime test-stat test-stat2 test-lfs tst-getcwd \
- tst-mknodat tst-mkfifoat tst-ttyname_r bug-ftw5 \
- tst-posix_fallocate tst-posix_fallocate64 \
- tst-fts tst-fts-lfs tst-open-tmpfile \
-- tst-copy_file_range tst-getcwd-abspath tst-lockf \
-+ tst-getcwd-abspath tst-lockf \
- tst-ftw-lnk tst-file_change_detection tst-lchmod
-
- # Likewise for statx, but we do not need static linking here.
-diff --git a/nptl/Makefile b/nptl/Makefile
-index e554a3898d..8373b6989d 100644
---- a/nptl/Makefile
-+++ b/nptl/Makefile
-@@ -282,7 +282,7 @@ tests = tst-attr2 tst-attr3 tst-default-attr \
- tst-atfork1 \
- tst-cancel1 tst-cancel2 tst-cancel3 tst-cancel4 tst-cancel4_1 \
- tst-cancel4_2 tst-cancel5 \
-- tst-cancel6 tst-cancel7 tst-cancel8 tst-cancel9 tst-cancel10 \
-+ tst-cancel6 tst-cancel8 tst-cancel9 tst-cancel10 \
- tst-cancel11 tst-cancel12 tst-cancel13 tst-cancel14 tst-cancel15 \
- tst-cancel16 tst-cancel17 tst-cancel18 tst-cancel19 tst-cancel20 \
- tst-cancel21 tst-cancel22 tst-cancel23 tst-cancel24 \
-@@ -319,6 +319,9 @@ tests = tst-attr2 tst-attr3 tst-default-attr \
- tst-robust-fork tst-create-detached tst-memstream \
- tst-thread-exit-clobber tst-minstack-cancel tst-minstack-exit \
- tst-minstack-throw \
-+ tst-cnd-basic tst-mtx-trylock tst-cnd-broadcast \
-+ tst-cnd-timedwait tst-thrd-detach tst-mtx-basic tst-thrd-sleep \
-+ tst-mtx-recursive tst-call-once tst-mtx-timedlock \
- tst-rwlock-pwn \
- tst-unwind-thread
-
-@@ -384,7 +387,7 @@ CFLAGS-tst-cleanup2.c += -fno-builtin
- CFLAGS-tst-cleanupx2.c += -fno-builtin
-
- tests += tst-cancelx2 tst-cancelx3 tst-cancelx4 tst-cancelx5 \
-- tst-cancelx6 tst-cancelx7 tst-cancelx8 tst-cancelx9 tst-cancelx10 \
-+ tst-cancelx6 tst-cancelx8 tst-cancelx9 tst-cancelx10 \
- tst-cancelx11 tst-cancelx12 tst-cancelx13 tst-cancelx14 tst-cancelx15 \
- tst-cancelx16 tst-cancelx17 tst-cancelx18 tst-cancelx20 tst-cancelx21 \
- tst-cleanupx0 tst-cleanupx1 tst-cleanupx2 tst-cleanupx3 tst-cleanupx4
-diff --git a/posix/Makefile b/posix/Makefile
-index 4507d84bf1..28075ed5bf 100644
---- a/posix/Makefile
-+++ b/posix/Makefile
-@@ -68,7 +68,7 @@ routines := \
- streams-compat
-
- aux := init-posix environ
--tests := test-errno tstgetopt testfnm runtests runptests \
-+tests := tstgetopt testfnm runtests runptests \
- tst-preadwrite tst-preadwrite64 test-vfork regexbug1 \
- tst-mmap tst-mmap-offset tst-getaddrinfo tst-truncate \
- tst-truncate64 tst-fork tst-fnmatch tst-regexloc tst-dir \
-@@ -89,7 +89,7 @@ tests := test-errno tstgetopt testfnm runtests runptests \
- tst-execve1 tst-execve2 tst-execle1 tst-execle2 \
- tst-execvp3 tst-execvp4 \
- tst-execvpe1 tst-execvpe2 tst-execvpe3 tst-execvpe4 \
-- tst-execvpe5 tst-execvpe6 \
-+ tst-execvpe6 \
- tst-getaddrinfo3 tst-fnmatch2 tst-cpucount tst-cpuset \
- bug-getopt1 bug-getopt2 bug-getopt3 bug-getopt4 \
- bug-getopt5 tst-getopt_long1 bug-regex34 bug-regex35 \
-diff --git a/resolv/Makefile b/resolv/Makefile
-index f131e4b014..6ee6570345 100644
---- a/resolv/Makefile
-+++ b/resolv/Makefile
-@@ -72,8 +72,6 @@ tests += \
-
- # Needs resolv_context.
- tests-internal += \
-- tst-resolv-res_init \
-- tst-resolv-res_init-thread \
- tst-resolv-res_ninit \
- tst-resolv-threads \
-
-diff --git a/sysdeps/unix/sysv/linux/Makefile b/sysdeps/unix/sysv/linux/Makefile
-index 60dc5cf9e5..158b2be0d2 100644
---- a/sysdeps/unix/sysv/linux/Makefile
-+++ b/sysdeps/unix/sysv/linux/Makefile
-@@ -95,7 +95,7 @@ sysdep_headers += sys/mount.h sys/acct.h sys/sysctl.h \
- bits/ipc-perm.h
-
- tests += tst-clone tst-clone2 tst-clone3 tst-fanotify tst-personality \
-- tst-quota tst-sync_file_range tst-sysconf-iov_max tst-ttyname \
-+ tst-quota tst-sync_file_range tst-sysconf-iov_max \
- test-errno-linux tst-memfd_create tst-mlock2 tst-pkey \
- tst-rlimit-infinity tst-ofdlocks tst-gettid tst-gettid-kill \
- tst-tgkill
---
-2.26.2
-
diff --git a/9999/0006-Gentoo-Disable-test-that-fails-because-of-the-gethos.patch b/9999/0006-Gentoo-Disable-test-that-fails-because-of-the-gethos.patch
deleted file mode 100644
index 30b2308..0000000
--- a/9999/0006-Gentoo-Disable-test-that-fails-because-of-the-gethos.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 3b6603fa966a37830261f1452d83f0aa80a1ec7d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
-Date: Wed, 17 Jan 2018 01:02:19 +0100
-Subject: [PATCH 06/12] Gentoo: Disable test that fails because of the
- gethostbyname4_r revert
-
----
- nss/Makefile | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/nss/Makefile b/nss/Makefile
-index 97bab5bb75..7a6ddebde2 100644
---- a/nss/Makefile
-+++ b/nss/Makefile
-@@ -68,7 +68,6 @@ tests-container = \
- # Tests which need libdl
- ifeq (yes,$(build-shared))
- tests += tst-nss-files-hosts-erange
--tests += tst-nss-files-hosts-multi
- tests += tst-nss-files-hosts-getent
- tests += tst-nss-files-alias-leak
- tests += tst-nss-files-alias-truncated
---
-2.26.2
-
diff --git a/9999/0007-Gentoo-Adapt-to-Gentoo-specific-etc-mail-aliases.patch b/9999/0007-Gentoo-Adapt-to-Gentoo-specific-etc-mail-aliases.patch
deleted file mode 100644
index 0196398..0000000
--- a/9999/0007-Gentoo-Adapt-to-Gentoo-specific-etc-mail-aliases.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 9de1a12253bcbec66b56b5058fcc04e775f59e75 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
-Date: Mon, 22 Oct 2018 22:34:13 +0200
-Subject: [PATCH 07/12] Gentoo: Adapt to Gentoo-specific /etc/mail/aliases
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Patch by pacho2
-
-Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-(cherry picked from commit 4e616cda056f471b799beba2b1cedc787ad4ecc0)
----
- nss/nss_files/files-alias.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/nss/nss_files/files-alias.c b/nss/nss_files/files-alias.c
-index 6aff7b4c10..bb6d9b5765 100644
---- a/nss/nss_files/files-alias.c
-+++ b/nss/nss_files/files-alias.c
-@@ -49,7 +49,7 @@ internal_setent (FILE **stream)
-
- if (*stream == NULL)
- {
-- *stream = fopen ("/etc/aliases", "rce");
-+ *stream = fopen ("/etc/mail/aliases", "rce");
-
- if (*stream == NULL)
- status = errno == EAGAIN ? NSS_STATUS_TRYAGAIN : NSS_STATUS_UNAVAIL;
---
-2.26.2
-