summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-03 00:41:09 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-03 00:41:56 +0200
commita62c3b78888d5e647aefb2a33f28088700e62d7b (patch)
tree9e82691331e9d48d005844dffd79978d279c1baf
parentDrop systemd-related config file patches, this will be done conditionally (diff)
downloadglibc-patches-a62c3b78888d5e647aefb2a33f28088700e62d7b.tar.gz
glibc-patches-a62c3b78888d5e647aefb2a33f28088700e62d7b.tar.bz2
glibc-patches-a62c3b78888d5e647aefb2a33f28088700e62d7b.zip
Regenerate patches at 2.34 release
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--9999/0001-Disable-ldconfig-during-install.patch16
-rw-r--r--9999/0002-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch14
-rw-r--r--9999/0003-Adapt-to-Gentoo-specific-etc-mail-aliases.patch15
-rw-r--r--9999/0004-Add-C.UTF-8-locale.patch6
-rw-r--r--9999/0005-Force-O0-in-conform-tests-to-survive-CC-changes.patch10
-rw-r--r--9999/0006-Fix-miscompilation-on-ia64-s-gcc-10.patch (renamed from 9999/0100-Fix-miscompilation-on-ia64-s-gcc-10.patch)8
6 files changed, 36 insertions, 33 deletions
diff --git a/9999/0001-Disable-ldconfig-during-install.patch b/9999/0001-Disable-ldconfig-during-install.patch
index 0dbdd9a..6080ceb 100644
--- a/9999/0001-Disable-ldconfig-during-install.patch
+++ b/9999/0001-Disable-ldconfig-during-install.patch
@@ -1,7 +1,7 @@
-From 8831dc046682b2f3fca8a0dc831e53afdebd4469 Mon Sep 17 00:00:00 2001
+From 479864345ca9f13e439b68681e13beb3dce60f7c Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
-Date: Wed, 1 Apr 2009 02:15:48 -0400
-Subject: [PATCH 1/5] Disable ldconfig during install
+Date: Tue, 3 Aug 2021 00:34:59 +0200
+Subject: [PATCH 1/6] Disable ldconfig during install
Do not bother running ldconfig on DESTDIR. It's a waste of time as we
won't use the result (portage will rebuild the cache after install).
@@ -15,17 +15,17 @@ https://bugs.gentoo.org/431038
1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile
-index 6dcfe40c25..68259babda 100644
+index f98d5a9e67..ef0077677c 100644
--- a/Makefile
+++ b/Makefile
-@@ -116,6 +116,7 @@ install-symbolic-link: subdir_install
- rm -f $(symbolic-link-list)
-
+@@ -110,6 +110,7 @@ elf/ldso_install:
+ ifeq (no,$(cross-compiling))
+ ifeq (yes,$(build-shared))
install:
+dont-bother-with-destdir:
-test ! -x $(elf-objpfx)ldconfig || LC_ALL=C \
$(elf-objpfx)ldconfig $(addprefix -r ,$(install_root)) \
$(slibdir) $(libdir)
--
-2.26.2
+2.31.1
diff --git a/9999/0002-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch b/9999/0002-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch
index 5604d9f..b256229 100644
--- a/9999/0002-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch
+++ b/9999/0002-Revert-sysdeps-posix-getaddrinfo.c-gaih_inet-Only-us.patch
@@ -1,7 +1,7 @@
-From cc789d18e5f6bb39ecca6ee8ec2872bd7a737160 Mon Sep 17 00:00:00 2001
+From 10aed4ee2c685613d190434649bbac896b364680 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
Date: Tue, 29 Aug 2017 22:58:50 +0200
-Subject: [PATCH 2/5] Revert " * sysdeps/posix/getaddrinfo.c (gaih_inet): Only
+Subject: [PATCH 2/6] Revert " * sysdeps/posix/getaddrinfo.c (gaih_inet): Only
use gethostbyname4_r"
This reverts commit 8479f23aa1d5e5477a37f46823856bdafaedfa46.
@@ -17,10 +17,10 @@ This makes tst-nss-files-hosts-multi fail. Disable it.
2 files changed, 2 insertions(+), 8 deletions(-)
diff --git a/nss/Makefile b/nss/Makefile
-index 97bab5bb75..7a6ddebde2 100644
+index bccf9f2806..c90fee2e4c 100644
--- a/nss/Makefile
+++ b/nss/Makefile
-@@ -68,7 +68,6 @@ tests-container = \
+@@ -74,7 +74,6 @@ tests-container = \
# Tests which need libdl
ifeq (yes,$(build-shared))
tests += tst-nss-files-hosts-erange
@@ -29,10 +29,10 @@ index 97bab5bb75..7a6ddebde2 100644
tests += tst-nss-files-alias-leak
tests += tst-nss-files-alias-truncated
diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
-index ed04e564f9..ce9e0d342d 100644
+index 838a68f022..1bb2263225 100644
--- a/sysdeps/posix/getaddrinfo.c
+++ b/sysdeps/posix/getaddrinfo.c
-@@ -739,13 +739,8 @@ gaih_inet (const char *name, const struct gaih_service *service,
+@@ -733,13 +733,8 @@ gaih_inet (const char *name, const struct gaih_service *service,
while (!no_more)
{
no_data = 0;
@@ -49,5 +49,5 @@ index ed04e564f9..ce9e0d342d 100644
{
while (1)
--
-2.26.2
+2.31.1
diff --git a/9999/0003-Adapt-to-Gentoo-specific-etc-mail-aliases.patch b/9999/0003-Adapt-to-Gentoo-specific-etc-mail-aliases.patch
index ca428cf..9588b09 100644
--- a/9999/0003-Adapt-to-Gentoo-specific-etc-mail-aliases.patch
+++ b/9999/0003-Adapt-to-Gentoo-specific-etc-mail-aliases.patch
@@ -1,7 +1,7 @@
-From dbe134e9eed77bfbbbbf80fa97f2b02b869bcf9c Mon Sep 17 00:00:00 2001
+From 60c8192d7a9245a2d1ad491d73b2677564d41374 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
Date: Mon, 22 Oct 2018 22:34:13 +0200
-Subject: Adapt to Gentoo-specific /etc/mail/aliases
+Subject: [PATCH 3/6] Adapt to Gentoo-specific /etc/mail/aliases
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@@ -17,10 +17,10 @@ Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
3 files changed, 17 insertions(+), 11 deletions(-)
diff --git a/nss/nss_files/files-alias.c b/nss/nss_files/files-alias.c
-index 43fb2c49a5..26b2cc86ad 100644
+index 2a4023b9a9..42c2a76d2f 100644
--- a/nss/nss_files/files-alias.c
+++ b/nss/nss_files/files-alias.c
-@@ -50,7 +50,7 @@ internal_setent (FILE **stream)
+@@ -43,7 +43,7 @@ internal_setent (FILE **stream)
if (*stream == NULL)
{
@@ -30,7 +30,7 @@ index 43fb2c49a5..26b2cc86ad 100644
if (*stream == NULL)
status = errno == EAGAIN ? NSS_STATUS_TRYAGAIN : NSS_STATUS_UNAVAIL;
diff --git a/nss/tst-nss-files-alias-leak.c b/nss/tst-nss-files-alias-leak.c
-index daebbf4ed4..095bb753a6 100644
+index 3b8af66294..91312d2552 100644
--- a/nss/tst-nss-files-alias-leak.c
+++ b/nss/tst-nss-files-alias-leak.c
@@ -45,27 +45,27 @@ prepare (int argc, char **argv)
@@ -79,7 +79,7 @@ index daebbf4ed4..095bb753a6 100644
FILE *fp = xfopen (path, "w");
for (int i = 0; i < many_aliases; ++i)
diff --git a/support/support_chroot.c b/support/support_chroot.c
-index 4f435c1ac1..e7ca2c714b 100644
+index e1628eb53b..4c58eba6a4 100644
--- a/support/support_chroot.c
+++ b/support/support_chroot.c
@@ -52,13 +52,19 @@ support_chroot_create (struct support_chroot_configuration conf)
@@ -103,3 +103,6 @@ index 4f435c1ac1..e7ca2c714b 100644
/* valgrind needs a temporary directory in the chroot. */
{
+--
+2.31.1
+
diff --git a/9999/0004-Add-C.UTF-8-locale.patch b/9999/0004-Add-C.UTF-8-locale.patch
index deea332..a9c3e22 100644
--- a/9999/0004-Add-C.UTF-8-locale.patch
+++ b/9999/0004-Add-C.UTF-8-locale.patch
@@ -1,7 +1,7 @@
-From 776636b6940ed6f3e08b0a67c290f241885384cb Mon Sep 17 00:00:00 2001
+From 5d65bb98c9ec8d3657b5566e9fb50d46319f65a3 Mon Sep 17 00:00:00 2001
From: Mike FABIAN <mfabian@redhat.com>
Date: Mon, 10 Aug 2015 15:58:12 +0200
-Subject: [PATCH 4/5] Add C.UTF-8 locale
+Subject: [PATCH 4/6] Add C.UTF-8 locale
Source:
https://src.fedoraproject.org/rpms/glibc/raw/master/f/glibc-c-utf8-locale.patch
@@ -283,5 +283,5 @@ index 0000000000..b2c2d1dc41
+END LC_MEASUREMENT
+
--
-2.26.2
+2.31.1
diff --git a/9999/0005-Force-O0-in-conform-tests-to-survive-CC-changes.patch b/9999/0005-Force-O0-in-conform-tests-to-survive-CC-changes.patch
index 02532cd..1262b6b 100644
--- a/9999/0005-Force-O0-in-conform-tests-to-survive-CC-changes.patch
+++ b/9999/0005-Force-O0-in-conform-tests-to-survive-CC-changes.patch
@@ -1,7 +1,7 @@
-From 84d03a910e28bb804453dad3e7600afe5e70256d Mon Sep 17 00:00:00 2001
+From 21bbee17488159cff563f90ed83aee59703cb21e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
Date: Fri, 14 Dec 2018 20:43:04 +0100
-Subject: [PATCH 5/5] Force -O0 in conform tests to survive $CC changes
+Subject: [PATCH 5/6] Force -O0 in conform tests to survive $CC changes
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@@ -22,7 +22,7 @@ Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
2 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/conform/conformtest.py b/conform/conformtest.py
-index cb2bd97eca..6076b615df 100644
+index f0405b7186..14d342e4c4 100644
--- a/conform/conformtest.py
+++ b/conform/conformtest.py
@@ -562,7 +562,7 @@ class HeaderTests(object):
@@ -46,7 +46,7 @@ index cb2bd97eca..6076b615df 100644
subprocess.check_call(cmd, shell=True)
bad_tokens = set()
diff --git a/conform/linknamespace.py b/conform/linknamespace.py
-index 1d27e4cfba..b0d2b9bbc2 100644
+index 66b16e244a..78c80d7645 100644
--- a/conform/linknamespace.py
+++ b/conform/linknamespace.py
@@ -157,7 +157,9 @@ def main():
@@ -61,5 +61,5 @@ index 1d27e4cfba..b0d2b9bbc2 100644
args.header)
with tempfile.TemporaryDirectory() as temp_dir:
--
-2.26.2
+2.31.1
diff --git a/9999/0100-Fix-miscompilation-on-ia64-s-gcc-10.patch b/9999/0006-Fix-miscompilation-on-ia64-s-gcc-10.patch
index 45ce958..9f1148b 100644
--- a/9999/0100-Fix-miscompilation-on-ia64-s-gcc-10.patch
+++ b/9999/0006-Fix-miscompilation-on-ia64-s-gcc-10.patch
@@ -1,7 +1,7 @@
-From 902100a88969641673e91408ff41352d08fa2aa7 Mon Sep 17 00:00:00 2001
+From 83b7893377b93d84e8bea1be08686b96cb98024d Mon Sep 17 00:00:00 2001
From: Sergei Trofimovich <slyfox@gentoo.org>
Date: Sat, 11 Jul 2020 20:06:51 +0300
-Subject: [PATCH] Fix miscompilation on ia64's gcc-10
+Subject: [PATCH 6/6] Fix miscompilation on ia64's gcc-10
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@@ -13,7 +13,7 @@ Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sysdeps/unix/sysv/linux/ia64/dl-sysdep.h b/sysdeps/unix/sysv/linux/ia64/dl-sysdep.h
-index 78fa6dd2c9..e526e02ff4 100644
+index 24650ce31f..20294e6ff0 100644
--- a/sysdeps/unix/sysv/linux/ia64/dl-sysdep.h
+++ b/sysdeps/unix/sysv/linux/ia64/dl-sysdep.h
@@ -32,7 +32,9 @@
@@ -28,5 +28,5 @@ index 78fa6dd2c9..e526e02ff4 100644
# define DL_SYSINFO_IMPLEMENTATION \
asm (".text\n\t" \
--
-2.26.2
+2.31.1