summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2013-08-27 01:52:21 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2013-08-27 01:52:21 +0000
commit22f46fe622caf5664a5615e3ede9bcaebd79955f (patch)
tree6abb5700af1ee270756cbbc8bd62dfb9b7c96283 /net-analyzer
parentIt works better if we define the variable we're trying to use. (diff)
downloadjmbsvicetto-22f46fe622caf5664a5615e3ede9bcaebd79955f.tar.gz
jmbsvicetto-22f46fe622caf5664a5615e3ede9bcaebd79955f.tar.bz2
jmbsvicetto-22f46fe622caf5664a5615e3ede9bcaebd79955f.zip
Bump cacti-spine to the 0.8.8b release.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild65
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8b-fix-ac-macro.patch12
3 files changed, 78 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 53d6666..b9595c5 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1 +1,2 @@
DIST cacti-spine-0.8.8a.tar.gz 623853 SHA256 2226070cd386a4955063a87e99df2fa861988a604a95f39bb8db2a301774b3ee SHA512 c6eb9492869488a5114cbfa2d372b1acb4bd1b0cecda2297f4b06cb1fe2fb95879b532923c230c72c9b50fbcfbf8f1d655c42075902c9f3a3ac4ee02d2e1913c WHIRLPOOL 080653346b698acff442c7d311ac805e6de410754a33dae698f6bd9328d3843734754fcf2eb417a870b1ac3d1effa5e830bec0d512b5f180da83b7c46ec2a74f
+DIST cacti-spine-0.8.8b.tar.gz 631603 SHA256 fc5d512c1de46db2b48422856e8c6a5816d110083d0bbbf7f9d660f0829912a6 SHA512 22be23012fbe165ea7d7097bbca1dda472bbe521f126e28e03f2faf394e67e050d95d88a878688b615dcdca2ec2b2166fdd48567503f1564f093797634a1809a WHIRLPOOL 86c065989fc58e926f4e76ec842dcaa276f4a8fc65ddbb0a7b2752cb6a52778464520b80a48fb612cece56600f03b5512ca5f01b97e9b58eb7f12cc6c62f49bb
diff --git a/net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild b/net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild
new file mode 100644
index 0000000..e626be8
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/cacti-spine-0.8.8a.ebuild,v 1.1 2013/04/27 15:09:23 pva Exp $
+
+EAPI="4"
+inherit autotools eutils
+
+UPSTREAM_PATCHES=""
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="net-analyzer/net-snmp
+ dev-libs/openssl
+ virtual/mysql"
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.8"
+
+if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ for i in ${UPSTREAM_PATCHES}; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/spine/patches/${PV}/${i}.patch"
+ done
+fi
+
+src_prepare() {
+ # Patch configure.ac to replace AM_CONFIG_HEADER with AC_CONFIG_HEADERS
+ epatch "${FILESDIR}/${P}-fix-ac-macro.patch"
+
+ if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -N" epatch "${DISTDIR}"/${i}.patch
+ done
+ fi
+
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine || die
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,} || die
+ dodoc ChangeLog README || die
+}
+
+pkg_postinst() {
+ elog "Please see the cacti's site for installation instructions:"
+ elog
+ elog "http://cacti.net/spine_install.php"
+ echo
+ ewarn "/etc/spine.conf should be readable by webserver, thus after you"
+ ewarn "decide on webserver do not forget to run the following command:"
+ ewarn
+ ewarn " # chown root:<wwwgroup> /etc/spine.conf"
+ echo
+}
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8b-fix-ac-macro.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8b-fix-ac-macro.patch
new file mode 100644
index 0000000..81fb6db
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8b-fix-ac-macro.patch
@@ -0,0 +1,12 @@
+diff -ur cacti-spine-0.8.8b-orig/configure.ac cacti-spine-0.8.8b/configure.ac
+--- cacti-spine-0.8.8b-orig/configure.ac 2013-08-27 01:45:32.400120526 +0000
++++ cacti-spine-0.8.8b/configure.ac 2013-08-27 01:45:42.350084943 +0000
+@@ -10,7 +10,7 @@
+ AC_LANG(C)
+
+ AM_INIT_AUTOMAKE(spine, 0.8.8b)
+-AM_CONFIG_HEADER(config/config.h)
++AC_CONFIG_HEADERS(config/config.h)
+
+ # static libraries
+ AC_ARG_WITH(static,