summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ninka/files/ninka-2.0_pre1_p20170402-makefile.patch')
-rw-r--r--dev-util/ninka/files/ninka-2.0_pre1_p20170402-makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/ninka/files/ninka-2.0_pre1_p20170402-makefile.patch b/dev-util/ninka/files/ninka-2.0_pre1_p20170402-makefile.patch
new file mode 100644
index 0000000..d5e046b
--- /dev/null
+++ b/dev-util/ninka/files/ninka-2.0_pre1_p20170402-makefile.patch
@@ -0,0 +1,22 @@
+--- ninka-orig/comments/Makefile
++++ ninka/comments/Makefile
+@@ -11,12 +11,13 @@
+ #DEBUG = -g -DDEBUG -DIODEBUG
+
+
+-all:
+- g++ $(DEBUG) $(OPTIONS) $(DEFINES) -c io.cpp
+- g++ $(DEBUG) $(OPTIONS) $(DEFINES) -c dformat.cpp
+- g++ $(DEBUG) $(OPTIONS) $(DEFINES) -c func.cpp
+- g++ $(DEBUG) $(OPTIONS) $(DEFINES) -c main.cpp
+- g++ -o $(NAME) main.o io.o dformat.o func.o
++all: $(NAME)
++
++%.o: %.cpp
++ $(CXX) $(CXXFLAGS) $(DEFINES) -c $<
++
++$(NAME): main.o io.o dformat.o func.o
++ $(CXX) $(LDFLAGS) -o $@ $^
+
+ install:
+ @echo -n "Installing binary: "