summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-15 08:45:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-15 09:43:42 +0200
commit2f973c00cfd81c411c8e5f567a2e445fd35baa92 (patch)
tree0320714476a6f8fa8e2aa70fdc5e0279c4cb42fe
parentapp-cdr/xfburn: Bump to 0.7.1 (diff)
downloadgentoo-2f973c00cfd81c411c8e5f567a2e445fd35baa92.tar.gz
gentoo-2f973c00cfd81c411c8e5f567a2e445fd35baa92.tar.bz2
gentoo-2f973c00cfd81c411c8e5f567a2e445fd35baa92.zip
dev-python/contourpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/contourpy/Manifest1
-rw-r--r--dev-python/contourpy/contourpy-1.2.0.ebuild57
-rw-r--r--dev-python/contourpy/files/contourpy-1.2.0-unicore.patch83
3 files changed, 0 insertions, 141 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index 25fde2b430b3..b85d4878838b 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,2 +1 @@
-DIST contourpy-1.2.0.gh.tar.gz 13440145 BLAKE2B c8082f69c3c8ad2b9a2d7a8e68941f1b741b0527161df371b501a32b8f0572a012aa2184b9f3ea943f45143f218f910180e31371683826d2b9b9431537c72cbd SHA512 91084ca659f796fb49f34840fb08a1a8f2a78ce8264668f5729550b1c46f316933c1d76ed87797bf58a059f0cf63e6efc58c92e44c57787fc8ad1ca16a21aa6e
DIST contourpy-1.2.1.gh.tar.gz 13440991 BLAKE2B 2e792ca990244f7890462b84a2f23e4fbc31fd8ce0a18bc8724767dfa4b5fc0a4271dc6989531423db58d567706a28ce95e680372dbf64bae93a09914353f3ac SHA512 2bb2ac7436cbee1ebc69e6edaf3166e294de32711cec506ce9a3132f1cf20ff8de70af27b432b81abb582c9fe30239f8724f68936908bdbf6348eb249eaae4d5
diff --git a/dev-python/contourpy/contourpy-1.2.0.ebuild b/dev-python/contourpy/contourpy-1.2.0.ebuild
deleted file mode 100644
index c242301e976d..000000000000
--- a/dev-python/contourpy/contourpy-1.2.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
-HOMEPAGE="
- https://pypi.org/project/contourpy/
- https://github.com/contourpy/contourpy/
-"
-SRC_URI="
- https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/wurlitzer[${PYTHON_USEDEP}]
- )
-"
-
-DISTUTILS_ARGS=(
- -Dwerror=false
-)
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/contourpy/contourpy/pull/327
- "${FILESDIR}/${P}-unicore.patch"
-)
-
-python_test() {
- local EPYTEST_IGNORE=(
- # linters
- tests/test_codebase.py
- )
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/contourpy/files/contourpy-1.2.0-unicore.patch b/dev-python/contourpy/files/contourpy-1.2.0-unicore.patch
deleted file mode 100644
index c25a1807dcd4..000000000000
--- a/dev-python/contourpy/files/contourpy-1.2.0-unicore.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From f948f821c705329a98bbcdcba5b642fe6c6f0b74 Mon Sep 17 00:00:00 2001
-From: matoro <matoro@users.noreply.github.com>
-Date: Wed, 15 Nov 2023 02:18:49 -0500
-Subject: [PATCH] Support running tests on unicore hosts
-
-All tests pass except those explicitly asserting that they are on a
-multicore system. Adds a conditional skip to those which are only
-useful on multicore hosts.
----
- tests/test_filled.py | 7 +++++--
- tests/test_lines.py | 7 +++++--
- tests/test_misc.py | 8 +-------
- 3 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/tests/test_filled.py b/tests/test_filled.py
-index b239f3b..c41e0d1 100644
---- a/tests/test_filled.py
-+++ b/tests/test_filled.py
-@@ -8,7 +8,7 @@
- from numpy.testing import assert_allclose, assert_array_equal
- import pytest
-
--from contourpy import FillType, contour_generator
-+from contourpy import FillType, contour_generator, max_threads
- from contourpy.util.data import random, simple
-
- from . import util_test
-@@ -734,7 +734,10 @@ def assert_chunk_offsets(offsets_or_none: list[cpy.OffsetArray | None]) -> None:
- @pytest.mark.threads
- @pytest.mark.parametrize("fill_type", FillType.__members__.values())
- @pytest.mark.parametrize("name, thread_count",
-- [("serial", 1), ("threaded", 1), ("threaded", 2)])
-+ [("serial", 1), ("threaded", 1),
-+ pytest.param("threaded", 2,
-+ marks = pytest.mark.skipif(
-+ max_threads() <= 1, reason = "executing on unicore host"))])
- def test_return_by_fill_type_chunk(
- xyz_chunk_test: tuple[cpy.CoordinateArray, ...],
- name: str,
-diff --git a/tests/test_lines.py b/tests/test_lines.py
-index 9608591..0b0833b 100644
---- a/tests/test_lines.py
-+++ b/tests/test_lines.py
-@@ -6,7 +6,7 @@
- from numpy.testing import assert_allclose, assert_array_equal
- import pytest
-
--from contourpy import LineType, contour_generator
-+from contourpy import LineType, contour_generator, max_threads
- from contourpy.util.data import random, simple
-
- from . import util_test
-@@ -707,7 +707,10 @@ def test_return_by_line_type(
- @pytest.mark.threads
- @pytest.mark.parametrize("line_type", LineType.__members__.values())
- @pytest.mark.parametrize("name, thread_count",
-- [("serial", 1), ("threaded", 1), ("threaded", 2)])
-+ [("serial", 1), ("threaded", 1),
-+ pytest.param("threaded", 2,
-+ marks = pytest.mark.skipif(
-+ max_threads() <= 1, reason = "executing on unicore host"))])
- def test_return_by_line_type_chunk(
- xyz_chunk_test: tuple[cpy.CoordinateArray, ...],
- name: str,
-diff --git a/tests/test_misc.py b/tests/test_misc.py
-index 5e46e3f..acd558a 100644
---- a/tests/test_misc.py
-+++ b/tests/test_misc.py
-@@ -2,13 +2,7 @@
-
- import numpy as np
-
--from contourpy import _remove_z_mask, contour_generator, max_threads
--
--
--def test_max_threads() -> None:
-- n = max_threads()
-- # Assume testing on machine with 2 or more cores.
-- assert n > 1
-+from contourpy import _remove_z_mask, contour_generator
-
-
- def test_nan() -> None: