summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-11-13 20:37:13 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-16 12:55:04 +0200
commit413fb275b1627096efe4bac40be087659962330a (patch)
tree0361825fcdae94e361419848d60d497849a19697
parentprofiles/features/wd40: New swell-foop-46 needs rustified librsvg (diff)
downloadgentoo-413fb275b1627096efe4bac40be087659962330a.tar.gz
gentoo-413fb275b1627096efe4bac40be087659962330a.tar.bz2
gentoo-413fb275b1627096efe4bac40be087659962330a.zip
app-editors/ghex: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34233 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--app-editors/ghex/ghex-46.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-editors/ghex/ghex-46.0.ebuild b/app-editors/ghex/ghex-46.0.ebuild
new file mode 100644
index 000000000000..0a2c139952a9
--- /dev/null
+++ b/app-editors/ghex/ghex-46.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4
+ >=gui-libs/libadwaita-1.2:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}