summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-27 14:53:01 -0500
committerMatt Turner <mattst88@gentoo.org>2024-12-11 12:21:31 -0500
commit6208af8875d0e69b7b8bb9f2b7497f0cc858c438 (patch)
tree4b74bc68cd39a837859ac41b9ff300957e82f57f
parentnet-im/synapse: add 1.121.0 (diff)
downloadgentoo-6208af8875d0e69b7b8bb9f2b7497f0cc858c438.tar.gz
gentoo-6208af8875d0e69b7b8bb9f2b7497f0cc858c438.tar.bz2
gentoo-6208af8875d0e69b7b8bb9f2b7497f0cc858c438.zip
virtual/opengl: Depend on libglvnd instead of mesa
Bug: https://bugs.gentoo.org/925627 Closes: https://bugs.gentoo.org/301337 Closes: https://bugs.gentoo.org/890334 Closes: https://github.com/gentoo/gentoo/pull/35556 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--profiles/default/linux/package.use.force6
-rw-r--r--virtual/opengl/opengl-8.ebuild18
2 files changed, 24 insertions, 0 deletions
diff --git a/profiles/default/linux/package.use.force b/profiles/default/linux/package.use.force
new file mode 100644
index 000000000000..155c529b4d30
--- /dev/null
+++ b/profiles/default/linux/package.use.force
@@ -0,0 +1,6 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Matt Turner <mattst88@gentoo.org> (2024-12-11)
+# Forced on to avoid potential breakage.
+virtual/opengl X
diff --git a/virtual/opengl/opengl-8.ebuild b/virtual/opengl/opengl-8.ebuild
new file mode 100644
index 000000000000..659c767daad7
--- /dev/null
+++ b/virtual/opengl/opengl-8.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for OpenGL implementation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="X"
+
+RDEPEND="
+ || (
+ media-libs/libglvnd[X?,${MULTILIB_USEDEP}]
+ dev-util/mingw64-runtime
+ )"