summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2025-01-08 12:16:40 +0100
committerViorel Munteanu <ceamac@gentoo.org>2025-01-08 18:26:04 +0200
commit940c2968a59939a79196725bec84af9ac0b2289e (patch)
treeacea7e071ccc9b3409f61074953ea5359dab1cb7
parentapp-crypt/certbot-nginx: add 3.1.0 (diff)
downloadgentoo-940c2968a59939a79196725bec84af9ac0b2289e.tar.gz
gentoo-940c2968a59939a79196725bec84af9ac0b2289e.tar.bz2
gentoo-940c2968a59939a79196725bec84af9ac0b2289e.zip
www-apps/rutorrent: add 5.1.5
Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-5.1.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 72281f4c2ccb..c39b45292d77 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,2 +1,3 @@
DIST rutorrent-4.3.10.tar.gz 2378291 BLAKE2B 2e676024e4b8fdec2a3e8b52715348dc7f4ae38adbdffb69e4f22b711d02eb49ce4de30e5e30e6a620819c39a6576c14b4fade6bc3b52a9212f1a96b23d96b99 SHA512 34a8f4b0bca721deb1d1fd017eed3cc722a785acafe2ca99ee56691028fce1fd92d069f69e2a4be18bef059c4c3f8a9d5eea54b86b9f6ed81401526337d7c856
DIST rutorrent-5.1.4.tar.gz 2694610 BLAKE2B aa02dc87dc4f228aa4ac24f7dea8d5c80500d275b8a60f29bea8098a784c413eac8b902d55395dfc51d83f6c0634dcf61e0c69a86732f69d30cde55135896b0d SHA512 fc318ece9199d203589cb28d0cf4565b7ce2288d00862c61d1ddcc713a77cc0682f446c983a81f59029c61ce09c5811871854a9c017864a657c9a4a27d039919
+DIST rutorrent-5.1.5.tar.gz 2694615 BLAKE2B 4cc69e83edf84dfc2a510949c62c1943ceddfecb224bc9647a1262ce09d27a70671c5493898b05b237108eec7f1cc8689f66276a535e42d90e7bb48d97607fed SHA512 f2178a6310d7b5cde2f3aa7c5650359002d8186db54a562b5a5161ef9253a429ef5e75c5968c6112f652240e13f65dd9d8dda94e3356bfa8987eb6e6c95c54d9
diff --git a/www-apps/rutorrent/rutorrent-5.1.5.ebuild b/www-apps/rutorrent/rutorrent-5.1.5.ebuild
new file mode 100644
index 000000000000..4d1d469d1e5c
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-5.1.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}