summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-01 06:38:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-01 07:06:18 +0200
commitbb639b13ab1d4dc47116a01a5ee3387c01f0bc05 (patch)
tree19b1f1f6c4e980429d99665acce688a3dab0442e
parentdev-python/alembic: Bump to 1.12.0 (diff)
downloadgentoo-bb639b13ab1d4dc47116a01a5ee3387c01f0bc05.tar.gz
gentoo-bb639b13ab1d4dc47116a01a5ee3387c01f0bc05.tar.bz2
gentoo-bb639b13ab1d4dc47116a01a5ee3387c01f0bc05.zip
dev-python/selenium: Bump to 4.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/selenium/Manifest2
-rw-r--r--dev-python/selenium/selenium-4.12.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index 16afac37e0fa..8f0bfefdf75e 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,2 +1,4 @@
DIST selenium-4.10.0.tar.gz 6465647 BLAKE2B ce6bb410753d922fb40f9613ad7a552c91a162f86a1efedfe39f3eee5af45db76cc8664aeb2d140186dfd5ff362c7654a019e21918f20439b1703cbd3572b005 SHA512 fca7b7cff54aad0771d60e4f85795e4205d2dd8dbf21abbd9ab2300fa80e7b033b08012d21792f18bf378e9c5234d82f410cc33f592d774eb94e418b325a2dd3
+DIST selenium-4.12.0.tar.gz 9141240 BLAKE2B c55adef082cd6da9c4457f8dfef2b967fa19656ab05b903248455e55bde92c7ce834822094266699e6fe75c3882c424cde606575a17ee4d38f1cef4136dcb654 SHA512 ec440ef1f3e7ca477da7014b5c7e5bef04f4fab9419dea5e3d9efe5f97d1fbdad4d588e64393094c7b2dcc50343873df3a16335fd1ba495e23a5027343c2eea4
DIST selenium-selenium-4.10.0.gh.tar.gz 89775386 BLAKE2B a20416826ae85b13f2312799b5fef1d079e142330a23b06d5b1cb2f3ec98e3c26e483e65bb99027e7b18eae80f13e74347afdc88c8facfc268220bbd93d8107a SHA512 bd8a0ac5e976119b8bff8a0b570479ece666369f0aef3806d173e956639c9df591047d0d333bb6ea5bdad740d84c5ee454d9749e0ebc502c5700a96bb146e182
+DIST selenium-selenium-4.12.0.gh.tar.gz 79906008 BLAKE2B 4ac3a4e134b29c1e866645a6ba3c799575b9f1d9854573edbcbe14a63f29fd05c822bfd97937091415e80d07bbeb3545f839b444e2e85e957b504cee8bc41ac7 SHA512 063780d555c41eabe0e3db3b7ddd3cb9793d0d733de457bc553235af158e76df7f29acb675a8987933037952393c2cd1940fbab81f515f3dd10dbc8daed13c17
diff --git a/dev-python/selenium/selenium-4.12.0.ebuild b/dev-python/selenium/selenium-4.12.0.ebuild
new file mode 100644
index 000000000000..2f638fc8415a
--- /dev/null
+++ b/dev-python/selenium/selenium-4.12.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
+TEST_TAG=${P}
+TEST_P=selenium-${TEST_TAG}
+
+DESCRIPTION="Python language binding for Selenium Remote Control"
+HOMEPAGE="
+ https://www.seleniumhq.org/
+ https://github.com/SeleniumHQ/selenium/tree/trunk/py/
+ https://pypi.org/project/selenium/
+"
+SRC_URI+="
+ test? (
+ https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
+ -> ${TEST_P}.gh.tar.gz
+ )
+"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
+ <dev-python/trio-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.17[${PYTHON_USEDEP}]
+ <dev-python/trio-websocket-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: we may need extra setup or deps
+ test/selenium
+
+ # expects vanilla certifi
+ test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
+ )
+
+ cd "${WORKDIR}/${TEST_P}/py" || die
+ rm -rf selenium || die
+ # https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
+ # seriously?
+ epytest -o "python_files=*_tests.py test_*.py"
+}