summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-09-23 13:55:15 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-09-23 14:00:01 -0500
commitdbae35153bd7980f4171052f8c5e5216b8cb6911 (patch)
treeb07502cff0766aff7ba4fe4ec96e5e04ee14cfcb
parentmedia-video/mpv: add 0.39.0 (diff)
downloadgentoo-dbae35153bd7980f4171052f8c5e5216b8cb6911.tar.gz
gentoo-dbae35153bd7980f4171052f8c5e5216b8cb6911.tar.bz2
gentoo-dbae35153bd7980f4171052f8c5e5216b8cb6911.zip
sys-apps/openrc: fix build
We dropped the use of --rootprefix upstream. The ebuild needs to pass --bindir and --sbindir to the build in order to install the appropriate portions of openrc in /bin and /sbin. Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 85e422dc5993..45409f32d5a4 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -52,13 +52,14 @@ PDEPEND="netifrc? ( net-misc/netifrc )"
src_configure() {
local emesonargs=(
+ --bindir=/bin
+ --sbindir=/sbin
$(meson_feature audit)
"-Dbranding=\"Gentoo Linux\""
$(meson_use newnet)
-Dos=Linux
$(meson_use pam)
$(meson_feature selinux)
- -Drootprefix="${EPREFIX}"
-Dshell=$(usex bash /bin/bash /bin/sh)
$(meson_use sysv-utils sysvinit)
)