summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-20 17:12:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-20 17:12:41 +0100
commite63f893f5e1f8726a7bd4c75749b72b03cd9fdaa (patch)
tree36d99dddeb63a1b7a4ebf490f7be726a094c3ced
parentdev-python/rapidfuzz: Enable pypy3 (diff)
downloadgentoo-e63f893f5e1f8726a7bd4c75749b72b03cd9fdaa.tar.gz
gentoo-e63f893f5e1f8726a7bd4c75749b72b03cd9fdaa.tar.bz2
gentoo-e63f893f5e1f8726a7bd4c75749b72b03cd9fdaa.zip
dev-python/cleo: Enable pypy3
Sponsored-by: Ex Makhina, Inc. <info-gentoo@exmakhina.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cleo/cleo-2.1.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/cleo/cleo-2.1.0.ebuild b/dev-python/cleo/cleo-2.1.0.ebuild
index eeb083c81bf9..d8fa9f6dea6a 100644
--- a/dev-python/cleo/cleo-2.1.0.ebuild
+++ b/dev-python/cleo/cleo-2.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
@@ -41,6 +41,16 @@ src_prepare() {
}
python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ tests/ui/test_exception_trace.py::test_render_debug_better_error_message_recursion_error
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_mock
epytest