summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-09 15:32:55 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-09 15:33:24 -0500
commiteba86b3f4a80dbb799e43ef7b2d878425cf45475 (patch)
tree627fdcb68d7aad68707194601730c87bcdc4e8f9
parentsys-kernel/linux-docs: Remove old. (diff)
downloadgentoo-eba86b3f4a80dbb799e43ef7b2d878425cf45475.tar.gz
gentoo-eba86b3f4a80dbb799e43ef7b2d878425cf45475.tar.bz2
gentoo-eba86b3f4a80dbb799e43ef7b2d878425cf45475.zip
dev-python/sphinxcontrib-spelling: add version 2.1.2
Package-Manager: portage-2.2.20
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/metadata.xml10
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild47
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
new file mode 100644
index 000000000000..c54633f2dc2a
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-spelling-2.1.2.tar.gz 35411 SHA256 c5ac488141408564cb60f355c50efd90b826a9fc7723738a07ab907a0384f086 SHA512 993f371e064e8748eb61faae649fb293b154a35955ff84d86fd041f4e2cc4c6e22c686007a67c3b63b0c50fc01ed226708f27db347e58847a46ca733c997d51f WHIRLPOOL 3258a991dbeb36ee1a3da64c64d2f05a1978a2c9348be1c2112afaf0cb40414cfe5f139d199cad7f534ade40db61666c133d70bc0605bd878e414e1dbe0f7e6a
diff --git a/dev-python/sphinxcontrib-spelling/metadata.xml b/dev-python/sphinxcontrib-spelling/metadata.xml
new file mode 100644
index 000000000000..02be8c5eb78f
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild
new file mode 100644
index 000000000000..edd93a46339c
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="http://bitbucket.org/dhellmann/sphinxcontrib-spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pyenchant-1.6.5[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-0.6[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
+ test? (
+ ${CDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}