summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-03-08 12:53:13 +0000
committerMichał Górny <mgorny@gentoo.org>2024-03-11 16:03:43 +0100
commit4b3f01f0bc616f42c6fd91b9c64cb2eeceb29045 (patch)
treeb179ac20d73902b0fbecd0e0eb5c43f728bce879 /app-admin/ngxtop
parentmedia-libs/libcdaudio: missing dies (diff)
downloadgentoo-4b3f01f0bc616f42c6fd91b9c64cb2eeceb29045.tar.gz
gentoo-4b3f01f0bc616f42c6fd91b9c64cb2eeceb29045.tar.bz2
gentoo-4b3f01f0bc616f42c6fd91b9c64cb2eeceb29045.zip
app-admin/ngxtop: migrate to PEP517 build
Closes: https://bugs.gentoo.org/909860 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/ngxtop')
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.3_pre141201-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r3.ebuild b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r3.ebuild
new file mode 100644
index 000000000000..873152bf9eb5
--- /dev/null
+++ b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="real-time metrics for nginx server (and others)"
+HOMEPAGE="https://github.com/lebinh/ngxtop"
+#SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.0.2-py3.patch )
+
+distutils_enable_tests pytest