summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-07-22 18:24:27 -0700
committerMatt Turner <mattst88@gentoo.org>2021-07-22 18:24:36 -0700
commita2c1d91747310654188a4c4b693d17751e7c9aeb (patch)
tree5e0ef59d1b8d45221a4762b6ae38cf3978435ec2 /app-admin/openrc-settingsd
parentnet-libs/webkit-gtk: Version bump to 2.32.2 (diff)
downloadgentoo-a2c1d91747310654188a4c4b693d17751e7c9aeb.tar.gz
gentoo-a2c1d91747310654188a4c4b693d17751e7c9aeb.tar.bz2
gentoo-a2c1d91747310654188a4c4b693d17751e7c9aeb.zip
app-admin/openrc-settingsd: Version bump to 1.1.0
Many thanks to our friends at postmarketOS for taking over maintainership of this project! Closes: https://bugs.gentoo.org/699530 Closes: https://bugs.gentoo.org/759616 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-admin/openrc-settingsd')
-rw-r--r--app-admin/openrc-settingsd/Manifest1
-rw-r--r--app-admin/openrc-settingsd/openrc-settingsd-1.1.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/openrc-settingsd/Manifest b/app-admin/openrc-settingsd/Manifest
index 213eaaedf696..6199a89dc72a 100644
--- a/app-admin/openrc-settingsd/Manifest
+++ b/app-admin/openrc-settingsd/Manifest
@@ -1 +1,2 @@
DIST openrc-settingsd-1.0.1.tar.xz 243552 BLAKE2B 2abf084c59ef310ca72bf2d528c6f8f04b3a502ea421247989e5356e759f2850f1749ffae7592ff30c92a0496db01e9d5e55c2a4ae9dbd3a9954414d4eabd31b SHA512 1f04a4b078a5fb659573daec0962f819af7eaff17a6213c4881726833cf32becd71dd820cd63767e2933465df26b3e4a3475d94f23e203a6977298965c709b21
+DIST openrc-settingsd-v1.1.0.tar.bz2 41781 BLAKE2B 1a508c5751a3b2c734b533ebdf72d4c5fa97b67743caf5e47f06fc505a286e92167715e0ec706528a4e9a74d0aed9d78d6b6b2d542c1df3781d5bd76ff700b91 SHA512 f63aa624097a806094c51a6da8fc6f4962c3302ea0acf02be17744db9d5caf4cfd68294a8e8916e62eeeca722cadc571715b9751730f9d9cf1f9be66e93510f7
diff --git a/app-admin/openrc-settingsd/openrc-settingsd-1.1.0.ebuild b/app-admin/openrc-settingsd/openrc-settingsd-1.1.0.ebuild
new file mode 100644
index 000000000000..7a0eee93c891
--- /dev/null
+++ b/app-admin/openrc-settingsd/openrc-settingsd-1.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="System settings D-Bus service for OpenRC"
+HOMEPAGE="https://gitlab.com/postmarketOS/openrc-settingsd/"
+SRC_URI="https://gitlab.com/postmarketOS/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.30:2
+ dev-libs/libdaemon:0=
+ sys-apps/dbus
+ sys-apps/openrc:=
+ sys-auth/polkit
+"
+RDEPEND="
+ ${DEPEND}
+ systemd? ( >=sys-apps/systemd-197 )
+ !systemd? ( sys-auth/nss-myhostname !sys-apps/systemd )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+ sed -i -e 's:/sbin/runscript:/sbin/openrc-run:g' data/init.d/openrc-settingsd.in || die
+}
+
+src_configure() {
+ econf \
+ --with-pidfile="${EPREFIX}"/run/openrc-settingsd.pid
+}
+
+src_install() {
+ default
+ if use systemd; then
+ # Avoid file collision with systemd
+ rm -vr "${ED}"/usr/share/{dbus-1,polkit-1} "${ED}"/etc/dbus-1 || die "rm failed"
+ fi
+}
+
+pkg_postinst() {
+ if use systemd; then
+ elog "You installed ${PN} with USE=systemd. In this mode,"
+ elog "${PN} will not start via simple dbus activation, so you"
+ elog "will have to manually enable it as an rc service:"
+ elog " # /etc/init.d/openrc-settingsd start"
+ elog " # rc-update add openrc-settingsd default"
+ fi
+}