summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-05-28 09:29:25 -0500
committerBen Kohler <bkohler@gentoo.org>2021-05-28 09:30:08 -0500
commite70d77e54a90ce6db5a18eb07c5979b1755ace1e (patch)
tree8dad287f8400bcac2d14f63997c577befe7f2039 /app-admin/xkcdpass/xkcdpass-1.19.2.ebuild
parentsys-cluster/kops: initial import (diff)
downloadgentoo-e70d77e54a90ce6db5a18eb07c5979b1755ace1e.tar.gz
gentoo-e70d77e54a90ce6db5a18eb07c5979b1755ace1e.tar.bz2
gentoo-e70d77e54a90ce6db5a18eb07c5979b1755ace1e.zip
app-admin/xkcdpass: bump to 1.19.2
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-admin/xkcdpass/xkcdpass-1.19.2.ebuild')
-rw-r--r--app-admin/xkcdpass/xkcdpass-1.19.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/xkcdpass/xkcdpass-1.19.2.ebuild b/app-admin/xkcdpass/xkcdpass-1.19.2.ebuild
new file mode 100644
index 000000000000..904553903feb
--- /dev/null
+++ b/app-admin/xkcdpass/xkcdpass-1.19.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Password generator inspired by XKCD 936"
+HOMEPAGE="https://github.com/redacted/XKCD-password-generator"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD CC-BY-3.0
+ l10n_de? ( GPL-3 )
+ l10n_it? ( CC-BY-SA-3.0 )
+ l10n_no? ( CC-BY-4.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="l10n_de l10n_en l10n_es l10n_fi l10n_fr l10n_it l10n_no l10n_pt"
+
+src_prepare() {
+ default
+
+ use l10n_de || rm ${PN}/static/ger-anlx
+ use l10n_en || rm ${PN}/static/{eff-short,eff-special,legacy}
+ use l10n_es || rm ${PN}/static/spa-mich
+ use l10n_fi || rm ${PN}/static/fin-kotus
+ use l10n_fr || rm ${PN}/static/fr-*
+ use l10n_it || rm ${PN}/static/ita-wiki
+ use l10n_no || rm ${PN}/static/nor-nb
+ use l10n_pt || rm ${PN}/static/pt-*
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}