summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-02 05:57:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-02 06:50:31 +0200
commit73c5020b4cf0e59dbc67b4b4d01743722b635e43 (patch)
tree36c399a3f2ac2149ba73479748ee2af614a42338 /app-admin
parentdev-python/boto3: Bump to 1.34.152 (diff)
downloadgentoo-73c5020b4cf0e59dbc67b4b4d01743722b635e43.tar.gz
gentoo-73c5020b4cf0e59dbc67b4b4d01743722b635e43.tar.bz2
gentoo-73c5020b4cf0e59dbc67b4b4d01743722b635e43.zip
app-admin/awscli: Bump to 1.33.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.33.34.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 7e9dea53102c..ad0b49ec62ba 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.33.27.gh.tar.gz 2758530 BLAKE2B c40db2483f0561078d1dc191e1d8c97ba
DIST aws-cli-1.33.31.gh.tar.gz 2765982 BLAKE2B 424422520aada1a5ab21843e61d5027937c1cd306936740ce6fe80ac8beadc5c5885727d716a7efe1890a3a3d7138710cb4b43a04d5293593d8b6fbf94e83ff9 SHA512 d7f860cb1b37c32a05550a43ff4c7e691f90ca8753fead9e1f2590556e589d6748ba163408ffbc7ecb1b1414a9df3590ffd5962aaf2acc6e49fff60a101034cb
DIST aws-cli-1.33.32.gh.tar.gz 2766766 BLAKE2B f3b0f319b9479fbfa2a6e51d174c7cfdaba8d22354da331702c7a707d5f1e2dbb971401071da6cd8533b0b24fea5cdca2180c01b33a1335e9ecec0d78337d5bc SHA512 8618365307b77eb31356663afe6982b6117e6047c5d209c75496f748217a65fb44eeeeee2fc6921cf12a030f079b44a4dd3e987437f99ff08aa3e76b02284399
DIST aws-cli-1.33.33.gh.tar.gz 2767435 BLAKE2B 2209a774624851df6c234c185956d94876835fe65de48f345457eb803846b82be7ef45bbea2000f462c78727125c53879888bc66eb0da9fc25dc59931147b09a SHA512 49e8ed59d9d1a3b7effe0b5407dbe6181fd5a17c194ad807f9a36053576b3db0f99d54ec0a45e78fc1a423bbdf411fa0aab2954ad05f3540da39ac8c7427a71d
+DIST aws-cli-1.33.34.gh.tar.gz 2768251 BLAKE2B 9524cef1f4bb192e5e73b332f38cbbd1add429ebb22ce4c250399646a7891295b70e7b1ab6868a2cb111f2e8a9db3245fc27571cb4e3fce4c6197bf5277f0ae5 SHA512 9b2db61e4e8481805154de16192a2ffe96c727f4b18b942d7bfed674edc9149d0de0f013d492b5f8abc3604c1386377192a526a4e3927ca8934e6e24357b78eb
diff --git a/app-admin/awscli/awscli-1.33.34.ebuild b/app-admin/awscli/awscli-1.33.34.ebuild
new file mode 100644
index 000000000000..c212ce9cac21
--- /dev/null
+++ b/app-admin/awscli/awscli-1.33.34.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).(z+118), sigh
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(( $(ver_cut 3-) + 118 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}