summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-22 05:39:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-22 06:48:54 +0200
commita1d8b599ce6f9c832c20e47f90dd2edeba9568cb (patch)
tree0392f2bc8c6cd3372a0a75bca647264044e64ce2 /app-admin
parentdev-python/boto3: Bump to 1.34.110 (diff)
downloadgentoo-a1d8b599ce6f9c832c20e47f90dd2edeba9568cb.tar.gz
gentoo-a1d8b599ce6f9c832c20e47f90dd2edeba9568cb.tar.bz2
gentoo-a1d8b599ce6f9c832c20e47f90dd2edeba9568cb.zip
app-admin/awscli: Bump to 1.32.110
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.110.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 742de093b4ef..ae0de0cfc251 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,4 +2,5 @@ DIST aws-cli-1.32.103.gh.tar.gz 2726436 BLAKE2B 7c08f29df7b0f786a99a7469263cb367
DIST aws-cli-1.32.107.gh.tar.gz 2727905 BLAKE2B 6790687edadc7ebf4bb8519ed9352961d002b95b157bf56b3ce02f50eef8e9eeeac39bb211816ab3e8e0f21dc2e41b9b3c179c77eab8c23d5650b1002fafff52 SHA512 b2f363ba8833058eb935fab311492c252dac4afff2f81e5ea70b9a8610c6e5b7e0b4ec090591af1a0c3692c3641ac1213cb8455d8ffac8a148d7ba0b7c7f4467
DIST aws-cli-1.32.108.gh.tar.gz 2728605 BLAKE2B 83606ebe909a4ee3d4f0d2875f56958b02b791d31d2fc770b1dc60072d31a56b6b7b5ef3ad79d8239b5f061f99f0dbfb554cab169bb99e6813f2b55cf8c185e2 SHA512 ce4bde840a4bfcdce91165bcf66139056e479322c80ef3211c98cd12c09d60d95bad8255f616dca4c11db3a26f3dca8149a42b76d163a8f02a88e6f986faff51
DIST aws-cli-1.32.109.gh.tar.gz 2728758 BLAKE2B bf3a8fdf1f240db7791183b15e97574d7345a84334664790dec3649e2803a5d16a55f5bfd8be80c9cd60feffd3e829c8b14843041d4805e47c2d23a6026f2848 SHA512 281177a017375e3379978c2322a5bb743c0432bb1fd9d5a3c6ee30463efc2006ed187b0a026811c94936c6c0916701c484fc8aa860d7411aeee8e1e7eb1848e4
+DIST aws-cli-1.32.110.gh.tar.gz 2729651 BLAKE2B 40f5065066ce69ada3b5dc7cc8b03fffc1171e1e76cf0c53bb7b135931e192fd9f84022af61f7bb0835b33c6248bd4bc8f5a30ded2cf9c98df0906ff43420830 SHA512 242e3196094520f1de1f64dc6f9e0e0969903b03a5d708f727561918e5043fb977b5175d889c7232214b56cb0c4c96a43a3c00e643b4b4715996245909a04e5c
DIST aws-cli-1.32.98.gh.tar.gz 2723261 BLAKE2B f854a78226a9480d2966e0dcc817e372de96f32723c28bd7189ed484ab24e8fa9f33a018b1b3193d1a5be82e1ad2b69b2d0d6642f004aa6fd601a68862cbbbdc SHA512 989ad96da152423001832a502935ed64a92ef61ba63f9f413fa07e84910d2aa905056bbfcf49202508d6d0a910b4a2969da27e736857e918077693909e4ca0ea
diff --git a/app-admin/awscli/awscli-1.32.110.ebuild b/app-admin/awscli/awscli-1.32.110.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.110.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}