summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/createrepo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/createrepo')
-rw-r--r--app-arch/createrepo/Manifest2
-rw-r--r--app-arch/createrepo/createrepo-0.10.3.ebuild57
-rw-r--r--app-arch/createrepo/files/createrepo-0.10.3-pkglist.patch15
-rw-r--r--app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch11
-rw-r--r--app-arch/createrepo/metadata.xml8
5 files changed, 93 insertions, 0 deletions
diff --git a/app-arch/createrepo/Manifest b/app-arch/createrepo/Manifest
new file mode 100644
index 000000000000..8c291450f3a6
--- /dev/null
+++ b/app-arch/createrepo/Manifest
@@ -0,0 +1,2 @@
+DIST createrepo-0.10.3.tar.gz 66004 SHA256 cd54621bef94c4a5ebffb5f19382050452d3e69763d2db4121c5d3881509ea6d SHA512 9e56625361dbc54667b42a4a8e84f46fd80dcb8d92ec9ff8532107981550612f946438061cc00b14c02f45aad18b33085bb0511a200715ba6d7c019785604a6e WHIRLPOOL 35de55956d7a69d6e7e5a32753336fc7808101330bb635e0712a06a76f7c5bd506b7cbaf0c728c099afe6a5927ad315e26ef44ce5cb57f6a9bb512dcf0af78df
+DIST createrepo-0.9.9-head.patch.bz2 14380 SHA256 74bdaea63c5f72d8814b0be5bc4b497188c8bd7c10fc3d66b6fd4058f98b58b8 SHA512 6d5e970e1489cef85cebedc3805bb1496c743c361b9bdda3d8df290f8e588d7d960272cf3c18e9c48fcdaf6a003b784a87aaea218da1ad68bf77446600980554 WHIRLPOOL 571319be8e0a7a559aa941046ea098e197f539d5156df12f3ac5ad87b133dbd7fc844ad208b7163110f8393a06eeb5c3a2fca2d09c870b3b59f457c6cb52634a
diff --git a/app-arch/createrepo/createrepo-0.10.3.ebuild b/app-arch/createrepo/createrepo-0.10.3.ebuild
new file mode 100644
index 000000000000..c49142d59e5d
--- /dev/null
+++ b/app-arch/createrepo/createrepo-0.10.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='xml'
+
+inherit python-single-r1 bash-completion-r1 eutils
+
+DESCRIPTION="Creates a common rpm-metadata repository"
+HOMEPAGE="http://createrepo.baseurl.org/"
+SRC_URI="http://createrepo.baseurl.org/download/${P}.tar.gz
+ http://dev.gentoo.org/~pacho/maintainer-needed/${PN}-0.9.9-head.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/urlgrabber-2.9.0[${PYTHON_USEDEP}]
+ >=app-arch/rpm-4.1.1[python,${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ >=app-arch/deltarpm-3.6_pre20110223[python,${PYTHON_USEDEP}]
+ dev-python/pyliblzma[${PYTHON_USEDEP}]
+ >=sys-apps/yum-3.4.3
+ ${PYTHON_DEPS}"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ python_export PYTHON_SITEDIR
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ten-changelog-limit.patch"
+ epatch "${FILESDIR}/${P}-pkglist.patch"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${ED}" \
+ PYTHON=true \
+ compdir="$(get_bashcompdir)" \
+ PKGDIR="${PYTHON_SITEDIR}/${PN}"
+ dodoc ChangeLog README
+ python_fix_shebang "${ED}"
+ python_optimize
+ python_optimize "${ED}/usr/share/createrepo"
+}
diff --git a/app-arch/createrepo/files/createrepo-0.10.3-pkglist.patch b/app-arch/createrepo/files/createrepo-0.10.3-pkglist.patch
new file mode 100644
index 000000000000..59fffc10ede1
--- /dev/null
+++ b/app-arch/createrepo/files/createrepo-0.10.3-pkglist.patch
@@ -0,0 +1,15 @@
+diff --git a/createrepo/__init__.py b/createrepo/__init__.py
+index b1875f6..85f2a3d 100644
+--- a/createrepo/__init__.py
++++ b/createrepo/__init__.py
+@@ -400,7 +400,9 @@ class MetaDataGenerator:
+ if self.conf.update:
+ self._setup_old_metadata_lookup()
+ # rpms we're going to be dealing with
+- if self.conf.pkglist:
++ if isinstance(self.conf.pkglist, MetaSack):
++ packages = self.conf.pkglist
++ elif self.conf.pkglist:
+ packages = []
+ for pkg in self.conf.pkglist:
+ if '://' in pkg: # remote
diff --git a/app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch b/app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch
new file mode 100644
index 000000000000..07b61067462e
--- /dev/null
+++ b/app-arch/createrepo/files/createrepo-0.10.3-ten-changelog-limit.patch
@@ -0,0 +1,11 @@
+--- createrepo/__init__.py~ 2011-01-26 12:14:30.000000000 -0500
++++ createrepo/__init__.py 2011-01-26 12:34:17.291441719 -0500
+@@ -96,7 +96,7 @@
+ self.mdtimestamp = 0
+ self.directory = None
+ self.directories = []
+- self.changelog_limit = None # needs to be an int or None
++ self.changelog_limit = 10 # needs to be an int or None
+ self.unique_md_filenames = True
+ self.additional_metadata = {} # dict of 'type':'filename'
+ self.revision = str(int(time.time()))
diff --git a/app-arch/createrepo/metadata.xml b/app-arch/createrepo/metadata.xml
new file mode 100644
index 000000000000..0e692af10e6c
--- /dev/null
+++ b/app-arch/createrepo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>alonbl@gentoo.org</email>
+ <name>Alon Bar-Lev</name>
+</maintainer>
+</pkgmetadata>