summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-11 19:24:18 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-13 21:21:29 -0400
commitb9318c2ca16ec1777474028de44ff7ae1de66bf2 (patch)
tree60016ccd19f4f7c42f3a636b2f36e9f940d2a1fe /app-backup/duplicity/duplicity-1.0.1-r1.ebuild
parentx11-misc/xdg-user-dirs-gtk: Version bump to 0.11 (diff)
downloadgentoo-b9318c2ca16ec1777474028de44ff7ae1de66bf2.tar.gz
gentoo-b9318c2ca16ec1777474028de44ff7ae1de66bf2.tar.bz2
gentoo-b9318c2ca16ec1777474028de44ff7ae1de66bf2.zip
app-backup/duplicity: change SRC_URI to pythonhosted.org
Closes: https://bugs.gentoo.org/876781 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-backup/duplicity/duplicity-1.0.1-r1.ebuild')
-rw-r--r--app-backup/duplicity/duplicity-1.0.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-backup/duplicity/duplicity-1.0.1-r1.ebuild b/app-backup/duplicity/duplicity-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..7b2826b2cea8
--- /dev/null
+++ b/app-backup/duplicity/duplicity-1.0.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_8 python3_9 python3_10 python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+SRC_URI="https://files.pythonhosted.org/packages/source/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}