summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-06-12 22:17:02 +0530
committerZac Medico <zmedico@gentoo.org>2024-06-13 12:10:44 -0700
commit30cd97c30ac71bbcd15630dcb86f1f7d407dd830 (patch)
tree86144975078cfdf38a8f38f165cc072214a5bda5 /app-containers
parentapp-containers/skopeo: update to 1.15.1 (diff)
downloadgentoo-30cd97c30ac71bbcd15630dcb86f1f7d407dd830.tar.gz
gentoo-30cd97c30ac71bbcd15630dcb86f1f7d407dd830.tar.bz2
gentoo-30cd97c30ac71bbcd15630dcb86f1f7d407dd830.zip
app-containers/podman-tui: update to 1.1.0
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> From: https://github.com/gentoo/gentoo/pull/37135 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/podman-tui/Manifest1
-rw-r--r--app-containers/podman-tui/podman-tui-1.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/podman-tui/Manifest b/app-containers/podman-tui/Manifest
index 238979100079..12a50f103e77 100644
--- a/app-containers/podman-tui/Manifest
+++ b/app-containers/podman-tui/Manifest
@@ -1,3 +1,4 @@
DIST podman-tui-0.18.0.tar.gz 15928626 BLAKE2B 80fd4f826a407b4eeeb664c065f836f12dd85cacab35003ad8fbcabf3eb69b3838bf02fb76269124d18c110370e42556cff8e348caabb100aa88a1994f99d4cc SHA512 77107a9e64b12fd5065698b7065909d5aa45ca49d749056cfb0f76aa2fd0f269708d3d75ecb4cab7939c30571510cdacebcdaac67549979873e3656e1af4db9f
DIST podman-tui-1.0.0.tar.gz 16208356 BLAKE2B c5ae4274cdc6c4d5abb9f9a18c82949a40a9f2894a9127d8bdf89b8a9445716cc985d8400833c890dec4524fd617babd5791e3062e9e7654ea93d66c34dfe181 SHA512 918b3efb823a543a439ae0f56c59ee2689961ac6e39a40054a7971ddf02056ca50c7c681ca03c45590e9fdfce1822f406bbf90f9b25563a0ef9ae75b88235a8c
DIST podman-tui-1.0.1.tar.gz 16252864 BLAKE2B 14b28a87aca99d90d9412d7bdd052604bdd8c05b262564eaa6821fd10f1f357bcb5f65d486da53a1abf98cfd45fadaf847f14942a27525136e70f83603ef6d85 SHA512 3c5ff5a77e885a0518a16e8d7fd0581a80b16650b546d2c736c50503c250797be1b8cb1a2da68ee1eed5a7a1dcdbcfa8344f37d0c6724c341470d05446a0591e
+DIST podman-tui-1.1.0.tar.gz 16091487 BLAKE2B e1d697a94da515c5ed896527bbf25f742a7ee315a5d83565377664c61fc65736beaef43d351dbbd64a0f6e254bed407278532a9a26eda7ec69637348ce60c5ce SHA512 d8e4710f489ac124ad11930c5051d9fc279166316bb85d952847e6a924f70b5cc64487f8c161878a21e8f88784c47c2f9f36b5b332c0736f48f3dd0ada92584a
diff --git a/app-containers/podman-tui/podman-tui-1.1.0.ebuild b/app-containers/podman-tui/podman-tui-1.1.0.ebuild
new file mode 100644
index 000000000000..beefef11ab58
--- /dev/null
+++ b/app-containers/podman-tui/podman-tui-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+DESCRIPTION="Terminal UI frontend for Podman"
+HOMEPAGE="https://github.com/containers/podman-tui"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
+else
+ SRC_URI="https://github.com/containers/podman-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+RESTRICT="test"
+
+src_compile() {
+ # parse tags from Makefile & make them comma-seperated as space-seperated list is deprecated
+ local BUILDTAGS=$(grep 'BUILDTAGS :=' Makefile | awk -F\" '{ print $2; }' | sed -e 's| |,|g;')
+ ego build -tags "${BUILDTAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}