summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-02-07 18:37:12 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-02-07 18:37:12 -0600
commit4c570f0a7a48931e92a4e107ac1f9f4acd0bcbef (patch)
treea30af335209e081088b55b869925d143bc96e436 /app-crypt/certbot-nginx/certbot-nginx-0.31.0.ebuild
parentapp-crypt/certbot-apache: 0.30.0 stable amd64/x86; 0.31.0 bump; cleanup (diff)
downloadgentoo-4c570f0a7a48931e92a4e107ac1f9f4acd0bcbef.tar.gz
gentoo-4c570f0a7a48931e92a4e107ac1f9f4acd0bcbef.tar.bz2
gentoo-4c570f0a7a48931e92a4e107ac1f9f4acd0bcbef.zip
app-crypt/certbot-nginx: 0.30.1 stable amd64/x86; 0.31.0 bump; cleanup
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-nginx/certbot-nginx-0.31.0.ebuild')
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.31.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.31.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.31.0.ebuild
new file mode 100644
index 000000000000..b84d186a8cd7
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-0.31.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=app-crypt/certbot-0.22.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.26.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"