summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2020-04-15 03:00:40 +0200
committerJonas Stein <jstein@gentoo.org>2020-04-15 03:01:36 +0200
commitbee1d6e7dce96fc0e85e1274f954a82461423242 (patch)
tree8302461875d9d58d47e1ffa67216a30b0660704a /app-crypt/rotix/rotix-0.83-r1.ebuild
parentsys-firmware/broadcom-bt-firmware: New package (diff)
downloadgentoo-bee1d6e7dce96fc0e85e1274f954a82461423242.tar.gz
gentoo-bee1d6e7dce96fc0e85e1274f954a82461423242.tar.bz2
gentoo-bee1d6e7dce96fc0e85e1274f954a82461423242.zip
app-crypt/rotix: bump EAPI=7
bump EAPI=7 update SRC_URI Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'app-crypt/rotix/rotix-0.83-r1.ebuild')
-rw-r--r--app-crypt/rotix/rotix-0.83-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/rotix/rotix-0.83-r1.ebuild b/app-crypt/rotix/rotix-0.83-r1.ebuild
new file mode 100644
index 000000000000..659781528a35
--- /dev/null
+++ b/app-crypt/rotix/rotix-0.83-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="Rotix allows you to generate rotational obfuscations"
+HOMEPAGE="https://github.com/shemminga/rotix"
+SRC_URI="https://github.com/shemminga/${PN}/releases/download/${PV}/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-devel/gettext"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/0.83-respect-CFLAGS-and-dont-strip.patch
+"${FILESDIR}"/rotix-0.83-locale.patch
+"${FILESDIR}"/rotix-0.83-interix.patch )
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ use elibc_glibc || append-flags -lintl
+ econf --i18n=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}