summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2023-02-14 16:35:05 -0600
committerSam James <sam@gentoo.org>2023-02-16 05:08:29 +0000
commit1635e78753ae661e1893d1559b05114a72a224de (patch)
tree33707d548f1f7eb6473de8089e027c0e37c3aa45 /app-crypt/tpm2-tools
parentapp-crypt/tpm2-tools: add missing python_check_deps and enable py3.11 (diff)
downloadgentoo-1635e78753ae661e1893d1559b05114a72a224de.tar.gz
gentoo-1635e78753ae661e1893d1559b05114a72a224de.tar.bz2
gentoo-1635e78753ae661e1893d1559b05114a72a224de.zip
app-crypt/tpm2-tools: Add missing python_check_deps
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tools')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
index 6b996f725753..9a0ccfad1d4a 100644
--- a/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,6 +36,14 @@ BDEPEND="virtual/pkgconfig
)
${PYTHON_DEPS}"
+python_check_deps() {
+ python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_configure() {
# tests fail with LTO enabbled. See bug 865275 and 865277
filter-lto