summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-11 22:25:27 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-11 22:29:19 +0000
commit987736474487824feeb7cafea18a783fad668e7b (patch)
tree0e6a4c0db5a42bb656a85f06b9c4eb6ddf34afc8 /app-doc/diveintopython/diveintopython-2.ebuild
parentdev-perl/JSON-RPC: Remove old (diff)
downloadgentoo-987736474487824feeb7cafea18a783fad668e7b.tar.gz
gentoo-987736474487824feeb7cafea18a783fad668e7b.tar.bz2
gentoo-987736474487824feeb7cafea18a783fad668e7b.zip
app-doc/diveintopython: Add ebuilds to install the famous "Dive Into Python" ebook.
Package-Manager: portage-2.2.26 Gentoo-Bug: https://bugs.gentoo.org/284506 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-doc/diveintopython/diveintopython-2.ebuild')
-rw-r--r--app-doc/diveintopython/diveintopython-2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-doc/diveintopython/diveintopython-2.ebuild b/app-doc/diveintopython/diveintopython-2.ebuild
new file mode 100644
index 000000000000..ead1ca4b2619
--- /dev/null
+++ b/app-doc/diveintopython/diveintopython-2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+MY_PV="5.4"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="'Dive Into Python' by Mark Pilgrim - Python 2.x book"
+HOMEPAGE="http://www.diveintopython.net/"
+SRC_URI="http://www.diveintopython.net/download/${PN}-html-${MY_PV}.zip -> ${P}.zip"
+LICENSE="FDL-1.1"
+SLOT="2"
+
+KEYWORDS="~amd64 ~ppc64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+}
+
+src_install() {
+ insinto /usr/share/doc/${PN}-${SLOT}
+ doins -r html/*
+ insinto /usr/share/doc/${PN}-${SLOT}/examples
+ doins -r py
+}