summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2021-12-24 01:56:57 +0100
committerJonas Stein <jstein@gentoo.org>2021-12-24 02:05:01 +0100
commit75bfdd65710373c4417c73eec9f87351880c1ae4 (patch)
tree8c58a82c7377806fb3882103f23a31dc770df99f /app-editors/ghex
parentapp-containers/k3d: Bump to version 5.2.2 (diff)
downloadgentoo-75bfdd65710373c4417c73eec9f87351880c1ae4.tar.gz
gentoo-75bfdd65710373c4417c73eec9f87351880c1ae4.tar.bz2
gentoo-75bfdd65710373c4417c73eec9f87351880c1ae4.zip
app-editors/ghex: add 4.0.0 alpha
Add 4.0.0 alpha version and mask it. Bug: https://bugs.gentoo.org/829834 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-4.0.0_alpha.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index 83a1cc9d0766..c7837ce8e75b 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1,2 +1,3 @@
DIST ghex-3.18.4.tar.xz 1420268 BLAKE2B 70a3027a2c228481ecbc6ae44c0a707c9858453e3af7bfc268b6e32a8496722cf117c1b2ce4dd798795a429dccd24e1fa9cb9d1a8c9c8fb5998243369f76ccc4 SHA512 6121a5986ee7d7f96bf7f401e155f8aa37f076af455bc68e43d1b5b02b63bc9aed3eba5209511d1b659eb4c9093ab5d9601c14a5e868d979e92a6d0ca0cf9ce2
DIST ghex-3.41.1.tar.xz 1499804 BLAKE2B dd75dc1cc5d847ae3b932ed0bb98b8e15f44943f76f0ba9f053c6770d05e31d211c9f75a910c93c09cf2de143db8fa0eda4fdb876a0ea3ed0534650e7ac36a65 SHA512 5eccf81c41f5ae56bfe5eab0fb843db0095c75080e7dfc0b19a4c71f40f89931e1cbcd2c58744a6b249d16e2a2e4f96513aaac4c41f46d3b5ae8b2bc851851a0
+DIST ghex-4.alpha.1.tar.gz 2165701 BLAKE2B f98758b657f2cc73913bb205439d265e8d8168c91080ca0e064decf277a7e300d9eb82a869951f846a66b5155016f69b0935b2877d24a0482a6b003a821adac2 SHA512 6e7e8d8ff0b981f14f48ed16d3b31ce51a0fb4c978c525cc9f3b2c06114bc1cfaf42e71ea98f1b0d33940a2f6b15a5e053228484259bdc4525bb18f2835b97c8
diff --git a/app-editors/ghex/ghex-4.0.0_alpha.ebuild b/app-editors/ghex/ghex-4.0.0_alpha.ebuild
new file mode 100644
index 000000000000..02e8fb9d1908
--- /dev/null
+++ b/app-editors/ghex/ghex-4.0.0_alpha.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ MY_PV="4.alpha.1"
+ SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/atk-1.0.0
+ >=dev-libs/glib-2.31.10:2
+ >=x11-libs/gtk+-3.3.8:3
+ gui-libs/gtk:4
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}