summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-03-07 02:25:46 -0500
committerTim Harder <radhermit@gentoo.org>2017-03-07 02:32:18 -0500
commit0ac94546834f7f1906897f31424e4cd20b475446 (patch)
tree2a9c79c4b07dc37d234444c65fe81a33c410c443 /app-editors/vile/vile-9.8s.ebuild
parentmedia-libs/raspberrypi-userland: Remove old versions. (diff)
downloadgentoo-0ac94546834f7f1906897f31424e4cd20b475446.tar.gz
gentoo-0ac94546834f7f1906897f31424e4cd20b475446.tar.bz2
gentoo-0ac94546834f7f1906897f31424e4cd20b475446.zip
app-editors/vile: version bump to 9.8s
Diffstat (limited to 'app-editors/vile/vile-9.8s.ebuild')
-rw-r--r--app-editors/vile/vile-9.8s.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-editors/vile/vile-9.8s.ebuild b/app-editors/vile/vile-9.8s.ebuild
new file mode 100644
index 000000000000..40b6bbe3511c
--- /dev/null
+++ b/app-editors/vile/vile-9.8s.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="perl"
+
+RDEPEND=">=sys-libs/ncurses-5.2:0=
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-eselect/eselect-vi"
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ $(use_with perl )
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_OPT_S="" install
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}