summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-28 00:18:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-28 00:25:52 +0100
commit2197e31115066755ac61eab8654ec7ed5490690a (patch)
treecba4253842fc3f3097feccc9b7295a330e2a3877 /app-editors
parentkde-misc/wacomtablet: Drop old (diff)
downloadgentoo-2197e31115066755ac61eab8654ec7ed5490690a.tar.gz
gentoo-2197e31115066755ac61eab8654ec7ed5490690a.tar.bz2
gentoo-2197e31115066755ac61eab8654ec7ed5490690a.zip
app-editors/kile: Add 2.9.91_p20171209 snapshot
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kile/Manifest1
-rw-r--r--app-editors/kile/kile-2.9.91_p20171209.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-editors/kile/Manifest b/app-editors/kile/Manifest
index db4cc61ffbf6..b4fad468692e 100644
--- a/app-editors/kile/Manifest
+++ b/app-editors/kile/Manifest
@@ -1,2 +1,3 @@
DIST kile-2.1.3.tar.bz2 4911212 BLAKE2B 5cbfb1853bdb1f35c8e53988265a7a1e1181b27f40aeed59524736195d568e42ee88ee17215c3ed83eb37c8ec3f67a29dea141c0c7fca31c0be444b975c64df2 SHA512 820cb5e2579f243ce87409aa4d483a58b0a2cf1d86bff72dd12264570bfe72e7819c88aa4333080f8281e54e8315e2c11f961b41f13a6215913dfa4f7bd3feda
DIST kile-2.9.91_p20171202.tar.gz 3624137 BLAKE2B ee2906a7345826428b7248eb1588a7cbfa43100f537f6ae316d4a425bf11fcfca19df016726934a7fb3c01094a3e824f20f511ee509683b0fc9c84c2d8db75af SHA512 1a08a4c3d71dddf66e1bb68000d3bb9ae458eb985d08d90b89d595993be277c09f37833bd77097716091c4701fcf3750da77f7f720995bcea4bb4bd6c065d691
+DIST kile-2.9.91_p20171209.tar.gz 3624273 BLAKE2B d6e4798869b8f5be7a2a6b00b1b067957245373f560a7485334ce1f3f932670a0cb8ef0b551fde2eea1d54a6114e8405025dbd3daea587a2d30b74fe614d332e SHA512 b7e4a6e434057cf04e8712f543cdd74a40659843b1e2777d0a031b5a665e1de34e36ec9b3f5d9bd3bf9202f9dca8595fcee9a81ab4875bc4b6da3a2fb449b2c6
diff --git a/app-editors/kile/kile-2.9.91_p20171209.ebuild b/app-editors/kile/kile-2.9.91_p20171209.ebuild
new file mode 100644
index 000000000000..de4d64e0a25b
--- /dev/null
+++ b/app-editors/kile/kile-2.9.91_p20171209.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=dab0507f1df74ee66f88bdb4b294179605df60f4
+KDE_HANDBOOK="forceoptional"
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks"
+HOMEPAGE="https://kile.sourceforge.io/"
+SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="FDL-1.2 GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pdf +png"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdoctools)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep okular)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qttest)
+ $(add_qt_dep qtwidgets)
+ pdf? ( app-text/poppler[qt5] )
+"
+RDEPEND="${DEPEND}
+ !app-editors/kile:4
+ $(add_kdeapps_dep konsole)
+ $(add_kdeapps_dep okular 'pdf?')
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ || (
+ app-text/dvipdfmx
+ >=app-text/texlive-core-2014
+ )
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ virtual/imagemagick-tools[png?]
+ )
+"
+
+DOCS=( kile-remote-control.txt )
+
+src_prepare() {
+ kde5_src_prepare
+
+ # I know upstream wants to help us but it doesn't work..
+ sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package pdf Poppler)
+ )
+
+ kde5_src_configure
+}