summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <meurerbernardo@gmail.com>2019-08-06 13:35:30 -0700
committerMichał Górny <mgorny@gentoo.org>2019-09-20 10:00:20 +0200
commitd5be6ee83c6f4e91f5b7c5ff06d1066594eedf00 (patch)
tree4ec7247885f6e7c08e97f1dc767381767910dffb /app-editors
parentapp-editors/neovim: add neovim-0.3.8 (diff)
downloadgentoo-d5be6ee83c6f4e91f5b7c5ff06d1066594eedf00.tar.gz
gentoo-d5be6ee83c6f4e91f5b7c5ff06d1066594eedf00.tar.bz2
gentoo-d5be6ee83c6f4e91f5b7c5ff06d1066594eedf00.zip
app-editors/neovim: yank neovim-0.3.7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/neovim-0.3.7.ebuild96
2 files changed, 0 insertions, 97 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index 45f4e564b406..6fd8fbd2136b 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1,3 +1,2 @@
DIST neovim-0.3.4.tar.gz 9231575 BLAKE2B 92e727264442794ae27642451c90381262f9882e26d9865a2ff6c1bc4060b070ab49cd11194c3a88dafecda5bc1909963b2cc8b382198dc7c117ba056b7a4ebe SHA512 fbf22ccffbb36c082bfe9a66b3d0180a78581102732a44ab7a5417aef517c88b69406491854613a1cf347ddab6fc6e277f959887556d2c0068cf181e4d88c36b
-DIST neovim-0.3.7.tar.gz 9231661 BLAKE2B 6eade77f8654bc95170f4c052c5700a6ad42aff920889bf4036e6ff931cdeeabb908aeedb44e68efca3500beb797cf2361e09d85456a2c17431e005a64bafff4 SHA512 1d770a4643a44da65f0a03c90e18e89f337b16ec3eca20dbffa21bcab10c836062ef82974437b64bd766f7b07317cd3dc8e3e72b9d5d0911b1d4f2c528cd20c2
DIST neovim-0.3.8.tar.gz 9233661 BLAKE2B 252a64d2ac5ca1f8e1695d3f0f694ac333d9d9179dc4c428a279534e455de4b8d2c0dc6e638f775bb28a940fc1254bad426f7cee1bffaa2dbf84deefe49d41dc SHA512 431d3df859b430570e3f927328b862945a15b1ac041108599670d32af6cccac9361a143fc6af27847529629a43a5e0a0afd98b1c826d4ee1e7570de3cf14f9c7
diff --git a/app-editors/neovim/neovim-0.3.7.ebuild b/app-editors/neovim/neovim-0.3.7.ebuild
deleted file mode 100644
index c3e917afd7fe..000000000000
--- a/app-editors/neovim/neovim-0.3.7.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils xdg-utils
-
-DESCRIPTION="Vim-fork focused on extensibility and agility."
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
- SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
-
-CDEPEND="
- dev-libs/libuv:0=
- dev-libs/msgpack:0=
- luajit? ( dev-lang/luajit:2 )
- !luajit? (
- dev-lang/lua:=
- dev-lua/LuaBitOp
- )
- tui? (
- dev-libs/libtermkey
- >=dev-libs/unibilium-2.0.0:0=
- )
- dev-libs/libvterm
- dev-lua/lpeg[luajit=]
- dev-lua/mpack[luajit=]
- jemalloc? ( dev-libs/jemalloc )
- net-libs/libnsl"
-
-DEPEND="
- ${CDEPEND}
- dev-util/gperf
- virtual/libintl
- virtual/libiconv
- app-eselect/eselect-vi"
-
-RDEPEND="
- ${CDEPEND}
- python? ( dev-python/neovim-python-client )
- ruby? ( dev-ruby/neovim-ruby-client )
- remote? ( dev-python/neovim-remote )
- clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
-
-CMAKE_BUILD_TYPE=Release
-
-src_prepare() {
- # use our system vim dir
- sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
- -i src/nvim/globals.h || die
-
- # add eclass to bash filetypes
- sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DFEAT_TUI=$(usex tui)
- -DENABLE_JEMALLOC=$(usex jemalloc)
- -DPREFER_LUA=$(usex luajit no yes)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- # install a default configuration file
- insinto /etc/vim
- doins "${FILESDIR}"/sysinit.vim
-
- # conditionally install a symlink for nvimpager
- if use nvimpager; then
- dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
- fi
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}