summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-08 00:07:28 +0100
committerSam James <sam@gentoo.org>2023-09-08 00:07:28 +0100
commite5ca19d6e79329cf930b21689556ba3d5ea8b743 (patch)
tree5c729dbc603218795f4d5f457bda9f27146bb80c /app-editors
parentsys-libs/slang: Stabilize 2.3.3 sparc, #913835 (diff)
downloadgentoo-e5ca19d6e79329cf930b21689556ba3d5ea8b743.tar.gz
gentoo-e5ca19d6e79329cf930b21689556ba3d5ea8b743.tar.bz2
gentoo-e5ca19d6e79329cf930b21689556ba3d5ea8b743.zip
app-editors/micro: add 2.0.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/micro/Manifest2
-rw-r--r--app-editors/micro/micro-2.0.12.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/micro/Manifest b/app-editors/micro/Manifest
index 6e00f4916dab..bd06ff2b16cd 100644
--- a/app-editors/micro/Manifest
+++ b/app-editors/micro/Manifest
@@ -81,3 +81,5 @@ DIST layeh.com%2Fgopher-luar%2F@v%2Fv1.0.7.zip 36857 BLAKE2B c4ff2a1bbc2dc984fc2
DIST micro-2.0.10.tar.gz 814030 BLAKE2B 8becaf7caa167747443e1aa3af32e96588af275d2b921fa88fe9d55b4eec22622cf7a68d85d47834159042100414855c5bb3f8b9f7c8d934f762ec63f4d40435 SHA512 06796270a6d99578ac36f3313dffb6ba56c5e8963c6b59562b4ef9e65036ae2ed21ce602b39ee08d2f3c54c501089166fdecc5719a1ca535d84960b3b4b67f72
DIST micro-2.0.11-deps.tar.xz 19390200 BLAKE2B 3f4e3a60395854e1dcba0ed69c7f6b95d7e1efa6897da01232e66b253a0ef2f88c29cc9628ddcc569dc5d4bc63ed21866fb5861ffdfb4de61ae5654f4b6a7ae4 SHA512 c4fcd2ce5d8e85bdaf969d7d2fec5b526ea650b7a58649dd3546f0164b10478e248eaeb1cf4fe371f44ff0a3cd70541e1c4751d01ac33a49a6bd853f78941436
DIST micro-2.0.11.tar.gz 549261 BLAKE2B 30c21d7747870a9a85a8fb552ec9035af5c42232f4d2ee0744c24671e78ee22ff5eea803fbc19fac704b49644df0597538950b735f955eecc921e681c0ad924c SHA512 3aa3dd10baaec9fa73b5c673c3d29eb8b4d04b468e36866118bcfc70dd638c50e56d51fc6085dcc7441a2ce0d9bbf742c37fd26a7e2b92d8b20844c8a7b53487
+DIST micro-2.0.12-deps.tar.xz 27563572 BLAKE2B 416548c7b2effa88f80aeb00e15645ace642859af9b3992ec8bc702237a2a17440d34a0ccdad4079933e38fec5ae4d06749a094d211d9fc9f7a11cca9b098a29 SHA512 157f655dfab205e918367c1ea9de849c3c90671bbdf50e8c869e239350f923c62540695839e114e44d6740c06bb0855d5aa139876fe38fe87d24e3162029daef
+DIST micro-2.0.12.tar.gz 562941 BLAKE2B b360560cb0e4b27739e4efc880c66e4e934e3b6515062fb853f29ca9ee21e62edfac8ab0d554bff0062089c20ef2ab11b7d28180b851774f25327c6da58793e2 SHA512 a03fe2b91914c423f0195e9a7c7d35c3c6a38ec2ba65ca8dd8719da38806f2bc5a7b10efb73f9a2ee884bdf3f2a71a04bc3404a7a811b4fb329ffdf41336b78a
diff --git a/app-editors/micro/micro-2.0.12.ebuild b/app-editors/micro/micro-2.0.12.ebuild
new file mode 100644
index 000000000000..a57e060fc7af
--- /dev/null
+++ b/app-editors/micro/micro-2.0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature desktop xdg
+
+DESCRIPTION="Modern and intuitive terminal-based text editor"
+HOMEPAGE="https://github.com/zyedidia/micro"
+SRC_URI="https://github.com/zyedidia/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="dev-vcs/git"
+
+src_compile() {
+ ego build -v -work -x -o ${PN} -ldflags \
+ "-X github.com/zyedidia/micro/v2/internal/util.Version=${PV} -X github.com/zyedidia/micro/v2/internal/util.CompileDate=$(date -u +%Y-%m-%dT%H:%M:%SZ)" \
+ ./cmd/micro
+}
+
+src_install() {
+ dobin ${PN}
+ doman ./assets/packaging/micro.1
+ domenu assets/packaging/micro.desktop
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Update desktop file mime cache
+ xdg_pkg_postinst
+
+ optfeature_header "Clipboard support with display servers:"
+ optfeature "Xorg" x11-misc/xsel x11-misc/xclip
+ optfeature "Wayland" gui-apps/wl-clipboard
+}