summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/company-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/company-mode')
-rw-r--r--app-emacs/company-mode/Manifest2
-rw-r--r--app-emacs/company-mode/company-mode-0.6.14.ebuild38
-rw-r--r--app-emacs/company-mode/company-mode-0.7.ebuild38
-rw-r--r--app-emacs/company-mode/files/50company-mode-gentoo.el2
-rw-r--r--app-emacs/company-mode/metadata.xml12
5 files changed, 92 insertions, 0 deletions
diff --git a/app-emacs/company-mode/Manifest b/app-emacs/company-mode/Manifest
new file mode 100644
index 000000000000..fe92e834f2a6
--- /dev/null
+++ b/app-emacs/company-mode/Manifest
@@ -0,0 +1,2 @@
+DIST company-mode-0.6.14.tar.gz 51776 SHA256 5472cd634bf09da4557f055d3615afdd5436f814f63923ad94ccbebe60ab5e08 SHA512 7b8c0b70dc9c010214e8671fd7393faa9d1dd0839f41d532eb93eda91c77b4c93f2145ad2d688011976bfbb45282f35b937f195499f29cda79147ec2815e94d9 WHIRLPOOL 1aeefc6e4a5d7e3696150c38187131811c88fd3e9478a401400a31a7f7f7e3aad42736cabb093398470f9b20041639143665bb9d7335e2ae40ccfab8d2ab91ce
+DIST company-mode-0.7.tar.gz 54670 SHA256 73d55d9288537800c23f5e9e5b6208dd5e36e29271dca1a6c3840ca20142a268 SHA512 375c8541a0c5b34fba37ea136c8549e6ec916c238bee8115f036d88f273d6bcb0c0f436a6193d3b4be6528945d8f85c605de8d340e903a9764f5ace664f8cf61 WHIRLPOOL 23e18a37be0a2c1f4c7ded455557a5503c8f25b910ce5c0f36d8b09a22bd4aa96a944b0363750fce6b111dc3854c896f1800ac4dad20f99c76d7e0c9829e6014
diff --git a/app-emacs/company-mode/company-mode-0.6.14.ebuild b/app-emacs/company-mode/company-mode-0.6.14.ebuild
new file mode 100644
index 000000000000..3c2782adf170
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.6.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="http://company-mode.github.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ropemacs"
+
+# Note: company-mode supports many backends, and we refrain from including
+# them all in RDEPEND. Only depend on things that are needed at build time.
+DEPEND="ropemacs? ( app-emacs/pymacs )"
+RDEPEND="${DEPEND}
+ ropemacs? ( dev-python/ropemacs )"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md NEWS.md"
+
+src_prepare() {
+ # Disable backends that require extra dependencies, unless they are
+ # selected by the respective USE flag
+
+ elog "Removing pysmell backend"
+ rm company-pysmell.el || die
+
+ if ! use ropemacs; then
+ elog "Removing ropemacs backend, as requested by USE=-ropemacs"
+ rm company-ropemacs.el || die
+ fi
+}
diff --git a/app-emacs/company-mode/company-mode-0.7.ebuild b/app-emacs/company-mode/company-mode-0.7.ebuild
new file mode 100644
index 000000000000..3c2782adf170
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="http://company-mode.github.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ropemacs"
+
+# Note: company-mode supports many backends, and we refrain from including
+# them all in RDEPEND. Only depend on things that are needed at build time.
+DEPEND="ropemacs? ( app-emacs/pymacs )"
+RDEPEND="${DEPEND}
+ ropemacs? ( dev-python/ropemacs )"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md NEWS.md"
+
+src_prepare() {
+ # Disable backends that require extra dependencies, unless they are
+ # selected by the respective USE flag
+
+ elog "Removing pysmell backend"
+ rm company-pysmell.el || die
+
+ if ! use ropemacs; then
+ elog "Removing ropemacs backend, as requested by USE=-ropemacs"
+ rm company-ropemacs.el || die
+ fi
+}
diff --git a/app-emacs/company-mode/files/50company-mode-gentoo.el b/app-emacs/company-mode/files/50company-mode-gentoo.el
new file mode 100644
index 000000000000..cd85457fe91e
--- /dev/null
+++ b/app-emacs/company-mode/files/50company-mode-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'company-mode "company" nil t)
diff --git a/app-emacs/company-mode/metadata.xml b/app-emacs/company-mode/metadata.xml
new file mode 100644
index 000000000000..91bd7f737518
--- /dev/null
+++ b/app-emacs/company-mode/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<use>
+ <flag name="ropemacs">Install backend for
+ <pkg>dev-python/ropemacs</pkg></flag>
+</use>
+<upstream>
+ <remote-id type="github">company-mode/company-mode</remote-id>
+</upstream>
+</pkgmetadata>